L2-006 树的遍历 (25 分)

L2-006 树的遍历 (25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

 

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
#include<string.h>
#include<map> 
using namespace std;
int hou[50];
int zhong[50];

struct Tree{
	int data;
	struct Tree *left,*right;
};
struct Tree * create(int h1,int h2,int z1,int z2)
{
	struct Tree *T;
	int i;
	int num;
	if(h1>h2)
	{
		T=NULL;
	}else{
		T=(struct Tree *)malloc(sizeof(struct Tree));
		T->data=hou[h2];
		for( i=z1;i<=z2;i++)
		{
			if(zhong[i]==hou[h2])
			{
				break;
			}
		}
		num=i-z1;
		T->left=create(h1,h1+num-1,z1,i);
		T->right=create(h1+num,h2-1,i+1,z2);
	}
	return T;
}
void cengci(struct Tree *T,int n)
{
	struct Tree *q,*p[50];
	int f=0,r=0,cnt=0;
	if(T)
	{
		p[r++]=T;
		while(f!=r)
		{
			q=p[f++];
			printf("%d",q->data);
			cnt++;
			if(cnt<n)
			{
				cout<<" ";
			}else{
				cout<<endl;
			}
			if(q->left!=NULL)
			{
				p[r++]=q->left;
			}
			if(q->right!=NULL)
			{
				p[r++]=q->right;
			}
		}
	}
}
int main()
{ 
    struct Tree *T;
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    {
    	cin>>hou[i];
	}
	for(int i=0;i<n;i++)
	{
		cin>>zhong[i];
	}
	T=create(0,n-1,0,n-1);
	cengci(T,n);
	return 0; 
}
 

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值