poj 2421 Constructing Roads 【生成树kruskal】

题目链接:http://poj.org/problem?id=2421

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 28209 Accepted: 12464

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

题意:给出一个矩阵表示点i和点j之间的距离,然后给你一个整数Q,接着有Q行,每行两个整数a,b表示a,b这两个点已经连通,求将整个图连通的最小代价和!

思路:就kruskal算法吧

刚开始一直RE,原因在于p[]这个数组开的太小,给出RE代码:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 1e3+10;
const int inf = 0x3f3f3f3f;
int pre[maxn];
int find(int x)
{
    if(pre[x]==x)
        return x;
    return find(pre[x]);
}
void join(int x,int y)
{
    int fx = find(x);
    int fy = find(y);
    if(fx != fy)
        pre[fx]=fy;
}
struct inp{
    int x,y,w;
}p[maxn];
bool cmp(inp a,inp b)
{
    return a.w<b.w;
}
int main()
{
    int n,b,cnt=0,m,ans=0,u,v;;
    cin>>n;
    for(int i=1;i<=n;i++)
        pre[i] = i;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            cin>>b;
            if(i>=j) continue;
            p[cnt].x = i;
            p[cnt].y = j;
            p[cnt++].w = b;
        }
    }
    sort(p+1,p+cnt+1,cmp);
    cin>>m;
    for(int i=1;i<=m;i++)
    {
        cin>>u>>v;
        join(u,v);
    }
    for(int i=1;i<=n*(n-1)/2;i++)
    {
        if(find(p[i].x) != find(p[i].y))
        {
            join(p[i].x,p[i].y);
            ans+=p[i].w;
        }
    }
    cout<<ans<<endl;
    return 0;
}

p数组开大点就可以了,得比n*(n-1)/2要大,下面给出AC代码:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 1e3+10;
const int inf = 0x3f3f3f3f;
int pre[maxn];
int find(int x)
{
    if(pre[x]==x)
        return x;
    return find(pre[x]);
}
void join(int x,int y)
{
    int fx = find(x);
    int fy = find(y);
    if(fx != fy)
        pre[fx]=fy;
}
struct inp{
    int x,y,w;
}p[maxn*maxn+100];
bool cmp(inp a,inp b)
{
    return a.w<b.w;
}
int main()
{
    int n,b,cnt=1,m,ans=0,u,v;;
    cin>>n;
    for(int i=1;i<=n;i++)
        pre[i] = i;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            cin>>b;
            if(i>=j) continue;
            p[cnt].x = i;
            p[cnt].y = j;
            p[cnt++].w = b;
        }
    }
    sort(p+1,p+cnt+1,cmp);
    cin>>m;
    for(int i=1;i<=m;i++)
    {
        cin>>u>>v;
        join(u,v);
    }
    for(int i=1;i<=n*(n-1)/2;i++)
    {
        if(find(p[i].x) != find(p[i].y))
        {
            join(p[i].x,p[i].y);
            ans+=p[i].w;
        }
    }
    cout<<ans<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值