poj 3061 Subsequence 【尺取】

题目链接:http://poj.org/problem?id=3061

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21799 Accepted: 9321

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题意:给定长度为n的数列整数a_{0},a_{1},\cdots ,a_{n-1}以及整数S。求出总和不小于S的连续子序列的长度的长度的最小值。如果解不存在,则输出0。

分析:尺取的入门题。

针对这一问题,我们稍加分析,我们设以a_{s}总和最初大于S时的连续子序列为a_{s}+\cdots +a_{t-1},这时有                                                                             a_{s+1}+\cdots +a_{t-2}<a_{s}+\cdots +a_{t-2}<S 

所以从a_{s+1} 开始总和最初超过S的连续子序列是a_{s+1}+\cdots +a_{m-1}的话,那必然有t\leq m。利用这一性质可以设计如下的算法,算法步骤:

(1)初始化s = t = sum = 0.
(2)只要依然有sum < S,就不断将sum增加a[t],并将t增加一
(3)如果(2)中无法满足sum >= S则终止。否则 更新结果ans = min(ans, t-s)
(4)将sum减去a[t],s增加1然后回到(2)

接下来就是贴代码了,有了算法就可以实现代码:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 1e6+10;
typedef long long ll;
ll a[maxn];
int n,S;
void solve()
{
    ll ans1 = n+1,t,s,sum; //ans1初始化为n+1,是为了便于判断结果
    t = s = sum = 0;
    for(;;)
    {
        while(t<n && sum<S)
        {
            sum += a[t];
            t++;
        }
        if(sum<S)  //全部取完还不满足的话就跳出循环
            break;
        ans1 = min(ans1,t-s); //这一步很是巧,建议模拟一遍
        sum -= a[s]; //符合要求的话就s++
        s++;
    }
    if(ans1 > n)
        cout<<'0'<<endl;
    else
        cout<<ans1<<endl;
}
int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>S;
        for(int i=0;i<n;i++)
            cin>>a[i];
        solve();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值