动态规划——Relocation 动态规划+状态压缩

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

At their old place, they will put furniture on both cars.
Then, they will drive to their new place with the two cars and carry the furniture upstairs.
Finally, everybody will return to their old place and the process continues until everything is moved to the new place.
Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input
The first line contains the number of scenarios. Each scenario consists of one line containing three numbers n, C1 and C2. C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input
2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98
Sample Output
Scenario #1:
2

Scenario #2:

3



这题是我第一次真正的用dp和状态压缩。。。

百度各位大神的题解差不多都看了,才明白一点。

orz!!!

最多有10个家具,每种家具对应每一位,所以用10位二进制来保存每种状态。

之后选出可行的方案进行dp。

具体见代码。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=1050;
int c[15];       //存放每个家具
int dp[maxn];    
int possible[maxn];  //每种可行方案对应的状态
bool flag[maxn];
int n, w1, w2;
int pos;
int ww;
bool check(int x)    //检查x是否可行
{
    int sum=0;
    memset(flag, false, sizeof(flag));
    flag[0]=true;
    for(int i=0; i<n; ++i)
        if((x>>i)&1)            //开始取x的每个二进制位判断
        {
            sum+=c[i];          //求x这种状态下对应的家具的体积和
            for(int j=w1; j>=c[i]; --j)     //j从w1开始是为了在第一辆车里面找出可行组合
                if(flag[j-c[i]])            
                    flag[j]=true;      //将x这种状态的各种组合标记下
        }
    if(sum>w1+w2)            //如果体积和大于了车所能装的体积和,那么x肯定是不可行的方案
        return false;
    for(int i=0; i<=w1; ++i)
        if(flag[i]&&(sum-i<=w2))    //判断:如果这种组合被标记过(即满足第一辆车),
            return true;            //且剩余家具的体积不大于第二辆,就说明是可行方案
    return false;               //如果以上所有操作都不满足,则x不可行
}
void init()
{
    pos=0;
    for(int i=1; i<=ww; ++i)
        if(check(i))
            possible[pos++]=i;   //将每种可行方案存入possible
}
int main()
{
    int t;
    scanf("%d", &t);
    int cas=0;
    while(t--)
    {
        scanf("%d%d%d", &n, &w1, &w2);
        for(int i=0; i<n; i++)
            scanf("%d", &c[i]);
        ww=(1<<n)-1;     //表示共有多少种状态
        init();
        dp[0]=0;         //什么都不用搬就是0次
        for(int i=1; i<=ww; ++i)
            dp[i]=INF;
        for(int i=0; i<pos; ++i)
            for(int j=ww; j>=0; --j)
            {
                if(dp[j]==INF)
                    continue;
                if((j&possible[i])==0)     //每个家具只用搬一次, 所以按位与应该是0
                    dp[j|possible[i]]=min(dp[j|possible[i]], dp[j]+1);
            }
        printf("Scenario #%d:\n%d\n", ++cas, dp[ww]);
        if(t)
            printf("\n");   //注意格式化输出,之前没看到pe了
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值