poj 2923 Relocation 状态压缩+01背包

Relocation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1626 Accepted: 657

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers nC1 and C2C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

Source

TUD Programming Contest 2006, Darmstadt, Germany


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int maxn=1111;
const int INF=0x3f3f3f3f;

int dp[maxn],g[maxn];
bool vis[maxn];
int a[11];
int n,c1,c2;

int judge(int x)
{
    int sum=0;
    memset(vis,false,sizeof(vis));
    vis[0]=true;
    for(int i=0;i<n;i++)
    {
        if((1<<i)&x)
        {
            sum+=a[i];
            for(int j=c1;j>=a[i];j--)
              if(vis[j-a[i]])
                 vis[j]=true;
        }
    }
    if(sum>c1+c2)
        return false;
    for(int i=0;i<=c1;i++)
    {
        if(vis[i]&&sum-i<=c2)
            return true;
    }
    return false;
}

int main()
{
    int t,cas=1;
    cin>>t;
    while(t--)
    {
      int i,j,s;
      cin>>n>>c1>>c2;
      if(c1>c2) swap(c1,c2);
      for(i=0;i<n;i++)
            scanf("%d",&a[i]);
      for(i=0;i<(1<<n);i++)
        dp[i]=INF;
      dp[0]=0;
      for(i=1,s=0;i<(1<<n);i++)
      {
          if(judge(i))
          {
              g[s++]=i;
          }
      }
      for(int i=0;i<s;i++)
      {
          for(j=((1<<n)-1);j>=0;j--)
          {
              if(dp[j]==INF)
                continue;
              if((j&g[i])==0)
              {
                  dp[j|g[i]]=min(dp[j|g[i]],dp[j]+1);
              }
          }
      }
      printf("Scenario #%d:\n%d\n\n",cas++,dp[(1<<n)-1]) ;
    }
    return 0;
}

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int min1(int x,int y)
{
    if(x>y)return y;
    return x;
}

int max1(int x,int y)
{
    if(x<y)return y;
    return x;
}

int main()
{
    int t,l,i,j,f1[1030],f2[1030],x,y,n,a[15],g[1030],o;
    scanf("%d",&t);
    for(l=1;l<=t;l++)
    {
        scanf("%d%d%d",&n,&x,&y);
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        memset(g,0,sizeof(g));
        o=0;
        for(i=1;i<(1<<n);i++)
        {
            if(i>=(1<<(o+1)))o++;
            g[i]=g[i-(1<<o)]+a[o+1];                 //g[i]为记录每种组合情况的货物重量,例如g[4]为第三件货物重量,g[5]为第一件+第三件货物重量
        }
        memset(f1,0,sizeof(f1));
        memset(f2,0,sizeof(f2));
        for(i=1;i<(1<<n);i++)
        {
            f1[i]=9999999;if(g[i]<=x)f1[i]=1;         //如可一次取完,则g[i]<=x,反之令其等于最大值,进入下式递推
            f2[i]=9999999;if(g[i]<=y)f2[i]=1;         //同f1
            if(f1[i]!=1||f2[i]!=1)
            {
                for(j=1;j<(1<<n);j++)
                {
                    if((i&j)==j)
                    {
                        f2[i]=min1(f2[i],f2[j]+f2[i-j]);                      //  f1[i]为记录每种组合情况的第一辆卡车需要载几次,例同上
                        f1[i]=min1(f1[i],f1[j]+f1[i-j]);                      //  f2[i]为第二辆,其余同f1
                    }

                }
            }
        }
        o=9999999;
        for(i=0;i<(1<<n);i++)
        {
            o=min1(o,max1(f1[((1<<n)-1)-i],f2[i]));                              //本题所求为两辆车一起跑最少跑几趟,故可用o=max(甲车,乙车)取o最小实现,i为枚举乙车所有组合情况,因需要全部运完,故甲车取乙车没运的
        }
        printf("Scenario #%d:\n%d\n\n",l,o);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值