数学——Area

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 

 
Figure 1: Example area. 

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 
Input
The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 
Output
The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.
Sample Input
2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3
Sample Output
Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

题意:给一个多边形,求边内的点,边上的点,多边形的面积。

思路:

1.pick定理:皮克定理是指一个计算点阵中顶点在格点上的多边形面积公式,该公式可以表示为2S=2a+b-2,其中a表示多边形内部的点数,b表示多边形边界上的点数,s表示多边形的面积。

2.向量的叉积求面积

3.求边上的点:对于由点a(x1, y1), b(x2, y2)组成的边所覆盖的点有gcd(abs(x1-x2))+gcd(abs(y1-y2))+1个

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=105;
struct node
{
    int x, y;
}p[maxn];
int gcd(int a, int b)
{
    if(b==0)
        return a;
    return gcd(b, a%b);
}
double area(node a, node b)
{
    return a.x*b.y-a.y*b.x;
}
int ab(int x)  //手写的abs,不知道为什么提交时加了cmath还是用不了abs
{
    if(x>=0)
        return x;
    else
        return -x;
}
int main()
{
    int t;
    scanf("%d", &t);
    for(int cas=1; cas<=t; cas++)
    {
        int n;
        scanf("%d", &n);
        double a=0.0;
        int sum=0;
        p[0].x=p[0].y=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d", &p[i].x, &p[i].y);
            int dx=ab(p[i].x);
            int dy=ab(p[i].y);
            sum+=gcd(dx, dy);
            p[i].x+=p[i-1].x;
            p[i].y+=p[i-1].y;
            a+=area(p[i], p[i-1]);
        }
        if(a<0)
            a=-a;
        printf("Scenario #%d:\n", cas);
        printf("%d %d %.1f\n\n", (int)(a/2-sum/2+1), sum, a/2);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值