POJ 2983 Is the Information Reliable?(差分约束)

Is the Information Reliable?

Time Limit: 3000MS Memory Limit: 131072K
Total Submissions: 15753 Accepted: 4884

Description

The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Draco established a line of defense called Grot. Grot is a straight line with N defense stations. Because of the cooperation of the stations, Zibu’s Marine Glory cannot march any further but stay outside the line.

A mystery Information Group X benefits form selling information to both sides of the war. Today you the administrator of Zibu’s Intelligence Department got a piece of information about Grot’s defense stations’ arrangement from Information Group X. Your task is to determine whether the information is reliable.

The information consists of M tips. Each tip is either precise or vague.

Precise tip is in the form of P A B X, means defense station A is X light-years north of defense station B.

Vague tip is in the form of V A B, means defense station A is in the north of defense station B, at least 1 light-year, but the precise distance is unknown.

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 1000) and M (1 ≤ M ≤ 100000).The next M line each describe a tip, either in precise form or vague form.

Output

Output one line for each test case in the input. Output “Reliable” if It is possible to arrange N defense stations satisfying all the M tips, otherwise output “Unreliable”.

Sample Input

3 4
P 1 2 1
P 2 3 1
V 1 3
P 1 3 1
5 5
V 1 2
V 2 3
V 3 4
V 4 5
V 3 5

Sample Output

Unreliable
Reliable

题意:

给你直线上n(n<=1e3)个点的编号,然后给你m(m<=1e5)条信息,每条信息:

P x y z   点x在点y的正北方距离z处

V x y   点x在点y的正北方,且距离相差至少为1

问你这m条信息是否可能正确。

思路:

显然是求距离最小值了,用差分约束的最长路来求。

建立一个超级源点,向每个点建一条权值为0的边,以保证连通性。

经过测试,只要m条信息合法就行。注意差分约束的不等式约束改为>=的形式。

关键还是建边。

#include<iostream>
#include<cmath>
#include<iomanip>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<string>
#include<queue>
#include<vector>
#include<map>
#define inf 0x3f3f3f3f
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=500005;
struct edge{
    int u;
    int v;
    int w;
    int next;
}e[maxn*4];
int cnt,head[maxn];
char s[10];
void add(int u,int v,int w){
    e[cnt].u=u;
    e[cnt].v=v;
    e[cnt].w=w;
    e[cnt].next=head[u];
    head[u]=cnt++;
}

int n,m,X;
bool vis[maxn];
int tim[maxn];
int d[maxn];
bool spfa(int s){
    queue<int> que;
    for(int i=0;i<maxn;i++)
    d[i]=-inf;
    memset(vis,0,sizeof(vis));
    memset(tim,0,sizeof(tim));
    que.push(s);
    d[s]=0;
    tim[s]++;
    vis[s]=1;
    while(!que.empty()){
        int tp=que.front();
        que.pop();
        vis[tp]=0;
        for(int i=head[tp];~i;i=e[i].next){
            int v=e[i].v;
            if(d[tp]+e[i].w>d[v]){
                d[v]=d[tp]+e[i].w;
                if(vis[v]==0){
                    vis[v]=1;
                    que.push(v);
                    if(++tim[v]>=n)
                        return 1;
                }
            }
        }
    }
    return 0;
}
void init()
{
    cnt=0;
    memset(head,-1,sizeof(head));
}
int main()
{
    int T,cas=1;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        for(int i=1;i<=m;i++)
        {
            char s[2];
            int x,y,z;
            scanf("%s%d%d",s,&x,&y);
            if(s[0]=='P') // x-y==z;
            {
                scanf("%d",&z);
                add(y,x,z);
                add(x,y,-z);
            }
            else // x-y>=1
            {
                add(y,x,1);
            }
        }
        for(int i=1;i<=n;i++)
        add(0,i,0);
        bool ans=spfa(0);
        //if(d[n]==-inf) ans=1;
        if(ans) printf("Unreliable\n");
        else printf("Reliable\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值