HDU--3605 Escape (多重匹配)

Problem Description
2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.
 

Input
More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most..
0 <= ai <= 100000
 

Output
Determine whether all people can live up to these stars
If you can output YES, otherwise output NO.
 

Sample Input
  
  
1 1 1 1 2 2 1 0 1 0 1 1
 

Sample Output
  
  
YES NO
 
思路:用一个二维数组存与星球匹配的人员的编号,若有人无法匹配,则输出NO
AC代码:
#include<cstdio>
#include<cstring>
const int N=100010;
bool vis[15];
int map[N][15],mat[15][N];
int cnt[15],vol[15];
int n,m;
bool find(int x)
{
    int i,j;
    for(i=0;i<m;i++)
    {
        if(!vis[i]&&map[x][i])
        {
            vis[i]=true;
            if(cnt[i]<vol[i])
            {
                mat[i][cnt[i]++]=x;
                return true;
            }
            for(j=0;j<cnt[i];j++)
            {
                if(find(mat[i][j]))
                {
                    mat[i][j]=x;
                    return true;
                }
            }
        }
    }
    return false;
}
int MMG()
{
    int i;
    memset(cnt,0,sizeof(cnt));
    for(i=0;i<n;i++)
    {
        memset(vis,false,sizeof(vis));
        if(!find(i)) return false;
    }
    return true;
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
                scanf("%d",&map[i][j]);
        }
        for(i=0;i<m;i++)
            scanf("%d",&vol[i]);
        if(MMG()) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值