hdu 4970 Killing Monsters(数组的巧妙运用) 2014多校训练第9场

Killing Monsters

                                                                       Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Problem Description
Kingdom Rush is a popular TD game, in which you should build some towers to protect your kingdom from monsters. And now another wave of monsters is coming and you need again to know whether you can get through it.

The path of monsters is a straight line, and there are N blocks on it (numbered from 1 to N continuously). Before enemies come, you have M towers built. Each tower has an attack range [L, R], meaning that it can attack all enemies in every block i, where L<=i<=R. Once a monster steps into block i, every tower whose attack range include block i will attack the monster once and only once. For example, a tower with attack range [1, 3] will attack a monster three times if the monster is alive, one in block 1, another in block 2 and the last in block 3.

A witch helps your enemies and makes every monster has its own place of appearance (the ith monster appears at block Xi). All monsters go straightly to block N.

Now that you know each monster has HP Hi and each tower has a value of attack Di, one attack will cause Di damage (decrease HP by Di). If the HP of a monster is decreased to 0 or below 0, it will die and disappear.
Your task is to calculate the number of monsters surviving from your towers so as to make a plan B.
 

Input
The input contains multiple test cases.

The first line of each case is an integer N (0 < N <= 100000), the number of blocks in the path. The second line is an integer M (0 < M <= 100000), the number of towers you have. The next M lines each contain three numbers, Li, Ri, Di (1 <= Li <= Ri <= N, 0 < Di <= 1000), indicating the attack range [L, R] and the value of attack D of the ith tower. The next line is an integer K (0 < K <= 100000), the number of coming monsters. The following K lines each contain two integers Hi and Xi (0 < Hi <= 10^18, 1 <= Xi <= N) indicating the ith monster’s live point and the number of the block where the ith monster appears.

The input is terminated by N = 0.
 

Output
Output one line containing the number of surviving monsters.
 

Sample Input
  
  
5 2 1 3 1 5 5 2 5 1 3 3 1 5 2 7 3 9 1 0
 

Sample Output
  
  
3
Hint
In the sample, three monsters with origin HP 5, 7 and 9 will survive.
 
题意:有n座塔,每座塔的攻击范围为[l,r],攻击力为d,有k个怪兽从这些塔前面经过,第i只怪兽初始的生命力为hp,出现的位置为x,终点为第n个格子。问最后有多少只怪兽还活着。
一开始用线段树写的,果断超时了。
其实只需开一个大小为n的数组attack,初值为0,对于每座塔的攻击(l,r,d),将attack[l]的值加上d,attack[r+1]的值减去d,然后对attack数组从前往后扫一遍,即可求出经过每个格子时受到的伤害;在从后往前扫一遍,便可求出从每个格子到第n个格子受到的总伤害,最后对于每只怪兽只需判断attack[x]和hp的大小即可。
#include<cstdio>
#include<cstring>
const int N = 100005;
typedef __int64 LL;
LL attack[N];
int main()
{
    int n, l, r, m, k, pos;
    LL d, hp;
    while(~scanf("%d",&n) && n) {
        memset(attack, 0, sizeof(attack));
        scanf("%d",&m);
        while(m--) {
            scanf("%d%d%I64d", &l, &r, &d);
            attack[l] += d;
            attack[r+1] -= d;
        }
        for(int i = 2; i <= n; i++) 
            attack[i] += attack[i-1];
        for(int i = n - 1; i > 0; i--)
            attack[i] += attack[i+1];
        int ans = 0;
        scanf("%d",&k);
        while(k--) {
            scanf("%I64d%d",&hp, &pos);
            if(attack[pos] < hp)
                ans++;
        }
        printf("%d\n", ans);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值