HDU4970 Killing Monsters

Killing Monsters


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 740 Accepted Submission(s): 370


Problem Description
Kingdom Rush is a popular TD game, in which you should build some towers to protect your kingdom from monsters. And now another wave of monsters is coming and you need again to know whether you can get through it.

The path of monsters is a straight line, and there are N blocks on it (numbered from 1 to N continuously). Before enemies come, you have M towers built. Each tower has an attack range [L, R], meaning that it can attack all enemies in every block i, where L<=i<=R. Once a monster steps into block i, every tower whose attack range include block i will attack the monster once and only once. For example, a tower with attack range [1, 3] will attack a monster three times if the monster is alive, one in block 1, another in block 2 and the last in block 3.

A witch helps your enemies and makes every monster has its own place of appearance (the ith monster appears at block Xi). All monsters go straightly to block N.

Now that you know each monster has HP Hi and each tower has a value of attack Di, one attack will cause Di damage (decrease HP by Di). If the HP of a monster is decreased to 0 or below 0, it will die and disappear.
Your task is to calculate the number of monsters surviving from your towers so as to make a plan B.


Input
The input contains multiple test cases.

The first line of each case is an integer N (0 < N <= 100000), the number of blocks in the path. The second line is an integer M (0 < M <= 100000), the number of towers you have. The next M lines each contain three numbers, Li, Ri, Di (1 <= Li <= Ri <= N, 0 < Di <= 1000), indicating the attack range [L, R] and the value of attack D of the ith tower. The next line is an integer K (0 < K <= 100000), the number of coming monsters. The following K lines each contain two integers Hi and Xi (0 < Hi <= 10^18, 1 <= Xi <= N) indicating the ith monster’s live point and the number of the block where the ith monster appears.

The input is terminated by N = 0.


Output
Output one line containing the number of surviving monsters.


Sample Input
5
2
1 3 1
5 5 2
5
1 3
3 1
5 2
7 3
9 1
0


Sample Output
3

Hint
In the sample, three monsters with origin HP 5, 7 and 9 will survive.



Author
SYSU


Source
2014 Multi-University Training Contest 9

题意:一条直线n个点,有m个塔,每个塔都能攻击一个范围[l,r],每秒造成伤害d,然后有k个怪物,每秒走一格,从1-n的某个位置出来,血量X,求有多少个怪物能够走出终点(n)。

大概是签到题吧,不过这题比赛被卡时限卡了好久,弱渣居然一看这题就想到了线段树。。。。不过最后线段树还是卡时限卡过了(后面附弱渣代码)。。。

正解是每个塔的范围是l到r,用一个数组,初始0,在l位置加上d,在r-1位置加上-d,然后从左往右扫一遍,把值加起来(a[i]+=a[i-1]),这个就是怪物在这个格子受到的伤害,然后从右往左扫一遍,就是怪物走到n受到的伤害了,然后比较大小就是,时间复杂度O(n),的确比线段树快.......

正解代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=100010;
__int64 a[MAXN];
int main()
{
    int n,m,k,i;
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(a,0,sizeof(a));
        scanf("%d",&m);
        int l,r,d;
        while(m--)
        {
            scanf("%d%d%d",&l,&r,&d);
            a[l]+=d,a[r+1]-=d;
        }
        for(i=2;i<=n;i++)
        {
            a[i]+=a[i-1];
        }
        for(i=n-1;i>=1;i--)
            a[i]+=a[i+1];
        scanf("%d",&k);
        __int64 h;
        int x;
        int ans=0;
        while(k--)
        {
            scanf("%I64d%d",&h,&x);
            if(h>a[x])
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

线段树。。。。

#include<stdio.h>
#include<string.h>
#define ll __int64
#define MAXN 100006
ll A[MAXN];
ll bb[MAXN];
ll sum[MAXN<<2];
ll mark[MAXN<<2];
void build(int l,int r,int rt)
{
    mark[rt]=sum[rt]=0;
    if(l==r)
        return ;
    int m=(l+r)>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
}
void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int l,int r,int rt)
{
    if(mark[rt])
    {
        mark[rt<<1]+=mark[rt];
        mark[rt<<1|1]+=mark[rt];
        int m=(l+r)>>1;
        sum[rt<<1]+=(m-l+1)*mark[rt];
        sum[rt<<1|1]+=(r-m)*mark[rt];
        mark[rt]=0;
    }
}
void update(int L,int R,ll val,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        mark[rt]+=val;
        sum[rt]+=(r-l+1)*val;
        return ;
    }
    pushdown(l,r,rt);
    int m=(l+r)>>1;
    if(L<=m)
        update(L,R,val,l,m,rt<<1);
    if(R>m)
        update(L,R,val,m+1,r,rt<<1|1);
    pushup(rt);
}
ll query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        return sum[rt];
    }
    pushdown(l,r,rt);
    int m=(l+r)>>1;
    int ret=0;
    if(L<=m)
        ret+=query(L,R,l,m,rt<<1);
    if(R>m)
        ret+=query(L,R,m+1,r,rt<<1|1);
    return ret;
}
void dfs(int l,int r,int rt)
{
    if(l==r)
    {
        bb[l]=sum[rt];
        return ;
    }
    int m=(l+r)>>1;
    pushdown(l,r,rt);
    dfs(l,m,rt<<1);
    dfs(m+1,r,rt<<1|1);
}
void solve(int N)
{
    dfs(1,N,1);
    int i;
    ll s=0;
    for(i=N;i>=1;i--)
    {
        A[i]=bb[i]+s;
        s=A[i];
    }
}
int main()
{
    int N;
    int M,K;
    while(scanf("%d",&N),N)
    {
        build(1,N,1);
        int l,r,x;
        ll h,d;
        scanf("%d",&M);
        while(M--)
        {
            scanf("%d%d%I64d",&l,&r,&d);
            update(l,r,d,1,N,1);
        }
        scanf("%d",&K);
        int ans=0;
        solve(N);
        while(K--)
        {
            scanf("%I64d%d",&h,&x);
            if(A[x]<h)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值