HDU 4970 Killing Monsters(树状数组VS思维)

Killing Monsters

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2768 Accepted Submission(s): 1040

Problem Description
Kingdom Rush is a popular TD game, in which you should build some towers to protect your kingdom from monsters. And now another wave of monsters is coming and you need again to know whether you can get through it.

The path of monsters is a straight line, and there are N blocks on it (numbered from 1 to N continuously). Before enemies come, you have M towers built. Each tower has an attack range [L, R], meaning that it can attack all enemies in every block i, where L<=i<=R. Once a monster steps into block i, every tower whose attack range include block i will attack the monster once and only once. For example, a tower with attack range [1, 3] will attack a monster three times if the monster is alive, one in block 1, another in block 2 and the last in block 3.

A witch helps your enemies and makes every monster has its own place of appearance (the ith monster appears at block Xi). All monsters go straightly to block N.

Now that you know each monster has HP Hi and each tower has a value of attack Di, one attack will cause Di damage (decrease HP by Di). If the HP of a monster is decreased to 0 or below 0, it will die and disappear.
Your task is to calculate the number of monsters surviving from your towers so as to make a plan B.

Input
The input contains multiple test cases.

The first line of each case is an integer N (0 < N <= 100000), the number of blocks in the path. The second line is an integer M (0 < M <= 100000), the number of towers you have. The next M lines each contain three numbers, Li, Ri, Di (1 <= Li <= Ri <= N, 0 < Di <= 1000), indicating the attack range [L, R] and the value of attack D of the ith tower. The next line is an integer K (0 < K <= 100000), the number of coming monsters. The following K lines each contain two integers Hi and Xi (0 < Hi <= 10^18, 1 <= Xi <= N) indicating the ith monster’s live point and the number of the block where the ith monster appears.

The input is terminated by N = 0.

Output
Output one line containing the number of surviving monsters.

Sample Input 5 2 1 3 1 5 5 2 5 1 3 3 1 5 2 7 3 9 1 0

Sample Output 3

Hint In the sample, three monsters with origin HP 5, 7 and 9 will
survive.
题目大意:
类似于一类塔防游戏。monster只能在一条长为N的直线上移动,有m个塔,每个塔有自己的防守范围以及在范围内每个点的伤害值;有k个monster,每个monster有自己的HP,以及刚开始出现在直线上的位置。问最后有多少monster能活着。

建立一个c数组。对于每个塔的属性(l,r,a)(范围为[l,r],伤害为a),使c[l]=a,c[r+1]=-a;扫完所有塔之后,求其前缀和数组,这个前缀和数组中每一个元素就代表怪物在当前点会受到的伤害,再从后面往前面扫一遍。复杂度为O(n)。
最后计算有多少个monster的HP能大于他走到最后受到的总伤害,即可得到答案。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int nn=100100;
typedef long long int in;
in c[nn],sum[nn],n;
in lowbit(in x)
{
    return x&(-x);
}
void add(in i,in a)
{
    while(i>=1)
    {
        c[i]+=a;
        i-=lowbit(i);
    }
}
in getsum(in x)
{
    in rnt=0;
    for(in i=x;i<=n;i+=lowbit(i))
    {
        rnt+=c[i];
    }
    return rnt;
}
int main()
{
    while(scanf("%lld",&n)!=EOF)
    {
        if(n==0)
            break;
        in l,r,a,m;
        memset(c,0,sizeof(c));
        scanf("%lld",&m);
        while(m--)
        {
            scanf("%lld%lld%lld",&l,&r,&a);
            add(r,a);
            add(l-1,-a);
        }
        sum[n+1]=0;
        for(in i=n;i>=1;i--)
            sum[i]=sum[i+1]+getsum(i);
        in k;
        scanf("%lld",&k);
        in ans=0;
        while(k--)
        {
            in h,hh;
            scanf("%lld%lld",&h,&hh);
            if(h>=sum[hh]) ans++;
        }
        printf("%lld\n",ans);
    }
    return 0;

}

非树状数组的写法
思路:
把l, r, d, 用数组a[l] += d; a[r+1] = -d; 然后从前向后扫一遍就 能计算出每一个格子的伤害,

把a从后向前扫一遍就能计算出 现在格子到最后一个格子的伤害。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#define LL __int64
const int maxn = 100000+10;
using namespace std;
LL a[maxn];

int main()
{
    int i, n, m, k, l, r, d, cnt, x;
    LL sum, h;
    while(~scanf("%d", &n) && n)
    {
        memset(a, 0, sizeof(a));
        cnt = 0;
        scanf("%d", &m);
        while(m--)
        {
            scanf("%d%d%d", &l, &r, &d);
            a[l] += d; a[r+1] += -d;
        }
        sum = 0;
        for(i = 1; i <= n; i++)
        {
            sum += a[i];
            a[i] = sum;
        }
        for(i = n-1; i >= 1; i--)
        a[i] += a[i+1];
        cin>>k;
        while(k--)
        {
            scanf("%I64d%d", &h, &x);
            if(a[x]<h)
            cnt++;
        }
        printf("%d\n", cnt);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值