POJ 2028 When Can We Meet? 枚举

When Can We Meet?
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5525 Accepted: 3038

Description

The ICPC committee would like to have its meeting as soon as possible to address every little issue of the next contest. However, members of the committee are so busy maniacally developing (possibly useless) programs that it is very difficult to arrange their schedules for the meeting. So, in order to settle the meeting date, the chairperson requested every member to send back a list of convenient dates by E-mail. Your mission is to help the chairperson, who is now dedicated to other issues of the contest, by writing a program that chooses the best date from the submitted lists. Your program should find the date convenient for the most members. If there is more than one such day, the earliest is the best.

Input

The input has multiple data sets, each starting with a line containing the number of committee members and the quorum of the meeting. 

N Q 
Here, N, meaning the size of the committee, and Q meaning the quorum, are positive integers. N is less than 50, and, of course, Q is less than or equal to N. 

N lines follow, each describing convenient dates for a committee member in the following format. 

M Date1 Date2 ... DateM 
Here, M means the number of convenient dates for the member, which is an integer greater than or equal to zero. The remaining items in the line are his/her dates of convenience, which are positive integers less than 100, that is, 1 means tomorrow, 2 means the day after tomorrow, and so on. They are in ascending order without any repetition and separated by a space character. Lines have neither leading nor trailing spaces. 

A line containing two zeros indicates the end of the input. 

Output

For each data set, print a single line containing the date number convenient for the largest number of committee members. If there is more than one such date, print the earliest. However, if no dates are convenient for more than or equal to the quorum number of members, print 0 instead.

Sample Input

3 2
2 1 4
0
3 3 4 8
3 2
4 1 5 8 9
3 2 5 9
5 2 4 5 7 9
3 3
2 1 4
3 2 5 9
2 2 4
3 3
2 1 2
3 1 2 9
2 2 4
0 0

Sample Output

4
5
0
2

Source


枚举题,数据量很小枚举一下,然后注意他要求出场的人数尽量多,所以我用了结构体拍了一下序
ac代码
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

int map[105][105];
int n,q,m;
struct node{
	int place;
	int num;
}nn[105];

bool cmp(node x,node y)
{
	if(x.num==y.num)
		return x.place<y.place;
	else
		return x.num>y.num;
}

int jdg()
{
	int i,j,num,cnt,flag;
	
	cnt=0;
	flag=0;
	for(j=0;j<105;j++)
	{
		num=0;
		for(i=0;i<105;i++)
		{
			if(map[i][j])	
				num++;
		}
		if(num>=q)
		{
			flag=1;
			nn[cnt].num=num;
			nn[cnt].place=j;
			cnt++;
		}
	}
	
	sort(nn,nn+cnt,cmp);
	if(flag)
		return nn[0].place;
	else
		return -1;
}

int main()
{
	int i,j,tmp,ans;
	
	while(~scanf("%d%d",&n,&q),n+q)
	{
		memset(map,0,sizeof(map));
		
		for(i=0;i<n;i++)
		{
			scanf("%d",&m);
			for(j=0;j<m;j++)
			{
				scanf("%d",&tmp);
				map[i][tmp]=1;
			}
		}
		ans=jdg();
		if(ans>=0)
			printf("%d\n",ans);
		else
			printf("0\n");
	}
	
	
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值