HDU 2859 Phalanx


Phalanx

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2081    Accepted Submission(s): 1023


Problem Description
Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix:
cbx
cpb
zcc
 

Input
There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.
 

Output
Each test case output one line, the size of the maximum symmetrical sub- matrix.
 

Sample Input
      
      
3 abx cyb zca 4 zaba cbab abbc cacq 0
 

Sample Output
      
      
3 3
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2858  2861  2860  2855  2856 
 



简单说一下,就是找最大的对称矩阵。

ac代码:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>

using namespace std;

int n;
char a[1010][1010];
int dp[1010][1010];

int main(){
	
	while(~scanf("%d",&n)){
		if(n == 0)
			break;
		memset(dp,0,sizeof(dp));
		for(int i=0;i<n;i++){
			scanf("%s",a[i]);
			dp[0][i]=1;	
		}
		int max1=1;
		for(int i=1;i<n;i++){
			for(int j=n-1;j>=0;j--){
				int x1=i-1,x2=j+1;
				int cnt=1;
				while( x1 >= 0 && x2 <n ){
					if(a[x1][j] != a[i][x2]){
						break ;
					}
					cnt++;
					x1--;
					x2++;
				}
				if(cnt > dp[i-1][j+1])
					dp[i][j]=dp[i-1][j+1]+1;
				else
					dp[i][j]=cnt;
					
				max1=max(dp[i][j],max1);
			}
		}
		printf("%d\n",max1);
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值