1001 A+B Format (20) java

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 


题目大意:输入两个数,把他们加起来,得到的数按照3位缩进输出。

思路:因为a和b均限制了大小,所以考虑用一个char ch = new char[9]大小的数组,

用i来控制数组进度,

并用count控制位数,

用for循环得到c %10的值,并存放到ch[i]中,初始化count = 0,如果count%3 == 0,则在ch数组中放入',' ,直到c = 0。

跑出for循环后,再倒着输出,需要注意用for循环输出的时候要先将i--;因为上一个for循环中的最后一次i++是多余的。


 


import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		char ch[] = new char[9];
		int a = input.nextInt();
		int b = input.nextInt();
		int c = a + b;
		if(c < 0) System.out.print("-");
		if(c == 0) System.out.print("0");
		int temp = Math.abs(c);
		int i;
		int count = 0;
		for(i=0; temp!=0; i++) {
			int t = temp % 10;
			ch[i] = (char)(t+'0');
			temp /= 10;
			count++;
			if(count%3 == 0 && temp!=0) ch[++i] = ',';
			
			
		}
		for(i--; i>=0 && ch[i] != ' '; i--)
			System.out.print(ch[i]);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值