hdu1072 Nightmare--DFS/BFS

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1072


一:原题内容

Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
  
  
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
  
  
4 -1 13

二:分析理解

     其实就是一个迷宫问题,讲述的是一个人做了一个噩梦,身处迷宫险境,只有一个出口,在规定时间内走出即可,此题的新颖处在于有个炸弹时间重设点,需要读者注意。


三:AC代码

     方法一:BFS

     参考自 http://blog.csdn.net/jw72jw/article/details/5803926

#define _CRT_SECURE_NO_DEPRECATE 
#define _CRT_SECURE_CPP_OVERLOAD_STANDARD_NAMES 1  

#include<iostream>
#include<queue>

using namespace std;

struct Node
{
	int x;
	int y;
	int step;//走过的步数
	int time;//剩余的时间
}start;

int maze[10][10];//迷宫
int mark[10][10];//标记走当前步后剩余的时间
int dir[4][2] = { 0,1,1,0,0,-1,-1,0 };//下右上左,逆时针四个方向
int T, N, M; 

void BFS();

int main()
{
	
	cin >> T;
	while (T--)
	{
		cin >> N >> M;
		for (int i = 0; i < N; i++)//数据输入
		{
			for (int j = 0; j < M; j++)
			{
				cin >> maze[i][j];
				mark[i][j] = 0;//初始化为0

				if (maze[i][j] == 2)//找到起点
				{
					start.x = i;
					start.y = j;
					start.step = 0;
					start.time = 6;
				}
			}
		}

		BFS();
	}
	return 0;
}

void BFS()
{
	queue<Node> q;
	q.push(start);
	mark[start.x][start.y] = start.time;
	Node p, temp;

	while (!q.empty())
	{
		p = q.front();
		q.pop();

		for (int i = 0; i < 4; i++)
		{
			temp = p;
			temp.x += dir[i][0];
			temp.y += dir[i][1];
			if (temp.x >= N || temp.x <= -1 || temp.y >= M || temp.y <= -1 || maze[temp.x][temp.y] == 0)
				continue;

			temp.step++;
			temp.time--;
			if (maze[temp.x][temp.y] == 3)//出口
			{
				cout << temp.step << endl;
				return;
			}
			else if (maze[temp.x][temp.y] == 4)//炸弹时间重设点
			{
				temp.time = 6;
			}

			if (temp.time >= 2 && mark[temp.x][temp.y] < temp.time)//剩余的时间大于等于2且
			{
				mark[temp.x][temp.y] = temp.time;
				q.push(temp);
			}
		}
	}

	cout << "-1\n";
}


      方法二:DFS




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值