hdu1531 King--单源最短路径&差分约束

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1531


一:原题内容

Problem Description
Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son.
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence.

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions.

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong.

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions.

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not.
 
Input
The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.
 
Output
The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null'' block of the input.
 
Sample Input
  
  
4 2 1 2 gt 0 2 2 lt 2 1 2 1 0 gt 0 1 0 lt 0 0

Sample Output
  
  
lamentable kingdom successful conspiracy

二:分析理解


三:AC代码

#include<iostream>  
#include<string.h>
#include<algorithm>  
#include<queue>

using namespace std;

struct Edge
{
	int v;//箭头指向的位置,在此不存储u节点
	int dis;//边的距离,也就是权值
	int next;//持有同一个u的下一个边
};

Edge edge[110];

int head[110];
bool visited[110];
int cnt[110];
int dis[110];

int n, m;

int si, ni;
char ch[3];
int ki;

int num;

void AddEdge(int u, int v, int w)
{
	edge[num].dis = w;
	edge[num].v = v;
	edge[num].next = head[u];
	head[u] = num++;
}

bool Spfa(int s)
{
	memset(visited, 0, sizeof(visited));
	memset(cnt, 0, sizeof(cnt));
	fill(dis, dis + 110, 99999999);//起初这里是写INT_MAX,但是OJ竟然AC了,,,但是这里是不能写INT_MAX的,下面的操作会使它溢出。

	dis[s] = 0;
	visited[s] = 1;

	queue<int> q;
	q.push(s);

	while (!q.empty())
	{
		int u = q.front();
		q.pop();
		visited[u] = 0;

		for (int i = head[u]; i != -1; i = edge[i].next)
		{
			int v = edge[i].v;
			if (dis[v] > dis[u] + edge[i].dis)
			{
				dis[v] = dis[u] + edge[i].dis;
				if (!visited[v])
				{	
					cnt[v]++;
					if (cnt[v] > n + 1)
						return false;

					q.push(v);
					visited[v] = 1;
				}
			}
		}
	}

	return true;
}

int main()
{
	while (scanf("%d", &n) && n)
	{
		scanf("%d", &m);

		num = 0;
		memset(head, -1, sizeof(head));

		while (m--)
		{
			scanf("%d %d %s %d", &si, &ni, ch, &ki);

			if (ch[0] == 'g')
				AddEdge(si + ni, si - 1, -ki - 1);//si-1可能会等于0,而si+ni又可能同时等于n,所以spfa是以大于n+1来判断负权回路
			else
				AddEdge(si - 1, si + ni, ki - 1);
		}

		for (int i = 0; i <= n; i++)//因为可能会出现两个互不关联的图,所以需要设置一个n+1来关联所有点
			AddEdge(n + 1, i, 0);

		if (Spfa(n + 1))
			printf("lamentable kingdom\n");
		else
			printf("successful conspiracy\n");
	}

	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值