Pseudoprime numbers (快速幂)

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-apseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-apseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

思路

这道题用到了快速幂的思想。快速幂主要是用二进制来计算的,这比用十进制的计算要简单的多,可以大大缩减程序的时间复杂度。

#include <iostream>
#include <stdio.h>

typedef long long ll;

using namespace std;

ll a,p;

bool ispri(ll num)//判断num是否为素数
{
    for(int i=2;i*i<num;i++)
    {
        if(num%i==0)
            return false;
    }
    return true;
}

ll Quickmul(ll a,ll b)
{
    ll ans=1;
    ll m=b;
    while(m)
    {
        if(m&1/*等价于m%2==1*/)
        {
            ans=(ans*a)%b;
        }
        a=(a*a)%b;
        m>>=1;//等价于m=m/2;
    }
    return ans;
}
int main()
{
    while(scanf("%d %d",&p,&a)!=EOF)
    {
        if(a==0&&p==0)
            break;
        if(ispri(p))
        {
            printf("no\n");
        }
        else if(Quickmul(a,p)==a)
        {
            printf("yes\n");
        }
        else
        {
            printf("no\n");
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值