Pseudoprime numbers

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

注意是先输入p,后输入的a!!

这道题的大概意思就是如果满足条件:

                        <1> a的p次方对p进行取模运算的结果仍为a

                        <2>p本身是一个合数

就输出"yes",否则输出"no"

判断<1>直接用二分快速幂,判断<2>可以用sqrt(p)来写。

#include<iostream>
using namespace std;
#include<cstring>
#include<algorithm>
#include<cmath>
#define ll long long
ll func(ll a, ll b, ll c) {
	int ans = 1;
	while (b) {
		if (b & 1)ans = ans * a % c;
		a = a * a % c;
		b >>= 1;
	}
	return ans;
}
bool f(ll n) {
	ll x = sqrt(n);
	for (int i = 2; i <= x; i++) {
		if (n % i == 0)return true;
	}
	return false;
}
int main() {
	ll p, a;
	while (cin >> p >> a && p && a) {
		if (func(a, p, p) == a &&f(p))cout << "yes" << endl;
		else cout << "no" << endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值