并查集----Wireless Network

                                                                                                              Wireless Network

                                                            Time Limit:10000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题意理解:
由于地震,该地区的网点暂时不能工作,题目要求输入N,D,接下来N行每行有两个坐标,代表N个网点,每个网点按编号1-N编号。
有两个操作,O  ----代表修好电脑。
            S----代表测试两个电脑是否能正常联系,能则输出“SUCCESS”,否则输出“FAIL”。
          如果两个网点的电脑正常工作且两个网点的距离不超过D则测试成功,如果两台电脑能通过另外一台电脑正常联系则测试通过。
 解题思路:
         并查集解题,开始初始化每个点的根节点,距离。
         vis[x]=1代表该点电脑能正常运行,vis[x]=0代表该点电脑为损坏的。
         如果输入为修理操作,则将该点设置为1,找到输入点的根节点,和每个电脑作比较看是否能联系,如果能就加入同一集合中。
         输入为测试操作时,找到两个点的根节点,看是否相等,是则success,否则 fail
code
#include <iostream>
#include<algorithm>
#include<cstdio>
#include<string.h>
using namespace std;
int N,D,pre[1005];
int vis[1005];
int dis[1005][1005];
struct node
{
    int x;
    int y;
}a[1005];

int find(int x)
{
    if(x!=pre[x])
        pre[x]=find(pre[x]);
    return pre[x];
}
void Union(int a,int b)
{
    a=find(a);
    b=find(b);
    pre[a]=b;
}
int dist(int i,int j)
{
    return((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y));
}
int main()
{
    scanf("%d%d",&N,&D);
    D*=D;
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=N;i++)
        scanf("%d%d",&a[i].x,&a[i].y);
    for(int i=1;i<=N;i++)
        pre[i]=i;
    for(int i=1;i<N;i++)
      for(int j=i;j<=N;j++)
         if(i==j)
         dis[i][j]=dis[j][i]=0;
      else
         dis[i][j]=dis[j][i]=dist(i,j);
    char op[2];
    while(scanf("%s",op)!=EOF)
    {
      
        if(op[0]=='O')
        {
            int x;
            scanf("%d",&x);
            if(!vis[x])
            {
                vis[x]=1;
                int a=find(x);
                for(int i=1;i<=N;i++)
                   if(i!=x&&vis[i]&&(find(i)==a || dis[i][x]<=D))
                      Union(i,x);
            }
        }
        if(op[0]=='S')
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(vis[x]&&vis[y])
            {
                int a=find(pre[x]);
                int b=find(pre[y]);
                if(a==b)
                  printf("SUCCESS\n");
                else
                  printf("FAIL\n");
            }
            else
               printf("FAIL\n");
        }
    }
    return 0;
}



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值