HDU 1875 (最小生成树)

Description

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。

Input

输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。 
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。 

Output

每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.

Sample Input

2
2
10 10
20 20
3
1 1
2 2
1000 1000

Sample Output

1414.2
oh!


注:是在符合条件的小岛上建桥,如果没有小岛符合条件才输出oh


1.普里姆算法:

#include <iostream>  // 普里姆算法
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;
#define sc(a) scanf("%d",&a)
#define nsc(a,b) scanf("%d %d",&a,&b)
#define pr(a) printf("%d\n",a)
#define mem(a,x) memset(a,x,sizeof(a))
#define lf(i,l,r) for(int i=l;i<r;i++)
#define inf 0x3f3f3f3f
#define N 105

int t,c,tol,vis[N],x[N],y[N];
double spot[N][N],dis[N],sum,maxn;
void solve()
{
    lf(i,1,c+1)
    dis[i]=spot[1][i];
    vis[1]=1;
    sum=0;
    lf(i,1,c)
    {
        maxn=inf;
        tol=-1;
        lf(j,1,c+1)
        {
            if(!vis[j]&&maxn>dis[j])
            {
                tol=j;
                maxn=dis[j];
            }
        }
        if(tol==-1)
            return ;
        vis[tol]=1;
        sum+=dis[tol];
        lf(j,1,c+1)
        {
            if(!vis[j])
                dis[j]=min(dis[j],spot[tol][j]);
        }
    }
    return ;
}

int main()
{
    int cnt;
    sc(t);
    while(t--)
    {
        sc(c);
        cnt=0;
        lf(i,1,c+1)
        nsc(x[i],y[i]);
        lf(i,1,c+1)
        {
            vis[i]=0;
            lf(j,1,c+1)
            {
                if(i!=j)
                {
                    spot[i][j]=sqrt((double)(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
                    if(spot[i][j]<10.0||spot[i][j]>1000.0)
                        spot[i][j]=inf;
                        else cnt++;
                }
                else spot[i][j]=inf;
            }
        }
        if(c*c-cnt-c<2)
        {
            printf("oh!\n");
            continue ;
        }
        solve();
        sum*=100;
        printf("%.1lf\n",sum);
    }
    return 0;
}



2.克鲁斯卡尔算法:

#include <iostream>  // 克鲁斯卡尔算法
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;
#define sc(a) scanf("%d",&a)
#define nsc(a,b) scanf("%d %d",&a,&b)
#define pr(a) printf("%d\n",a)
#define mem(a,x) memset(a,x,sizeof(a))
#define lf(i,l,r) for(int i=l;i<r;i++)
#define inf 0x3f3f3f3f
#define N 105

int t,n,cnt,x[N],y[N],p[N];
double sum;
struct node
{
    int s;
    int e;
    double v;
} spot[N*N];

int cmp(node x,node y)
{
    return x.v<y.v;
}

int Find(int x)
{
    if(x!=p[x])
    {
        p[x]=Find(p[x]);
    }
    return p[x];
}

void solve()
{
    sum=0;
    lf(i,1,cnt)
    {
        int xx=Find(spot[i].s);
        int yy=Find(spot[i].e);
        if(xx!=yy)
        {
            p[xx]=yy;
            sum+=spot[i].v;
        }
    }
}

int main()
{
    sc(t);
    while(t--)
    {
        cnt=1;
        sc(n);
        lf(i,1,n+1)
        nsc(x[i],y[i]);
        lf(i,1,n+1)
        {
            p[i]=i;
            lf(j,i+1,n+1)
            {
                sum=sqrt((double)(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
                if(sum>=10&&sum<=1000)
                {
                    spot[cnt].s=i;
                    spot[cnt].e=j;
                    spot[cnt++].v=sum;
                }
            }
        }
        if(cnt==1)
        {
            printf("oh!\n");
            continue;
        }
        sort(spot+1,spot+cnt,cmp);
        solve();
        sum*=100;
        printf("%.1lf\n",sum);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值