hdu 1016 Prime Ring Problem

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

先弄一张素数表;

然后进行深搜;

#include<iostream>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
bool flag[21]={0};
int ans[21]={1};
int isprime[]={3,5,7,11,13,17,19,23,29,31,37};
bool find_p(int n)
{
    for(int i=0;i<11;++i)
    {
        if(n==isprime[i]) return true;
    }
    return false;
}
void dfs(int n,int i)
{
    if(i==n&&find_p(ans[0]+ans[n-1]))
    {
        cout<<ans[0];
        for(int i=1;i<n;++i)
            cout<<" "<<ans[i];
        cout<<endl;
    }
    else
    {
        for(int j=2;j<=n;++j)
        {
            if(flag[j]!=1&&find_p(j+ans[i-1]))
            {
                ans[i]=j;
                flag[j]=1;
                dfs(n,i+1);
                flag[j]=0;
            }
        }
    }
}
int main()
{
    int n,kase=0;
    while(scanf("%d",&n)!=EOF)
    {
        ++kase;
        memset(flag,0,sizeof(flag));
        printf("Case %d:\n",kase);
        dfs(n,1);
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值