本题要求编写程序,将给定字符串中的大写英文字母按以下对应规则替换:
A —>Z
B —>Y
C —>X
……
X —>C
Y —>B
Z —>A
输入格式:
输入在一行中给出一个不超过80个字符、并以回车结束的字符串。
输出格式:
输出在一行中给出替换完成后的字符串。
输入样例:
Only the 11 CAPItaL LeTtERS are replaced.
输出样例:
Lnly the 11 XZKRtaO OeGtVIH are replaced.
#include <stdio.h>
#include <string.h>
int main()
{
char s[80];
gets(s);
int len = strlen(s);
int i;
for(i = 0; i < len; i++)
{
if(s[i] >= 'A'&&s[i] <= 'Z')
{
s[i] = 155 - s[i];
//注意如何替换
}
}
for(i = 0; i < len; i++)
{
printf("%c", s[i]);
}
return 0;
}