找到出勤最多的人-hebust

根据教师的花名册,找到出勤最多的人。

输入格式:
出勤记录单行给出,数据直接使用空格分割。

输出格式:
单行输出(若有多人,人名直接使用空格分割,结尾处没有空格)。

输入样例:
在这里给出一组输入。例如:

zs ls ww ml zs ls ml zs ww

输出样例:
在这里给出相应的输出。例如:

zs
import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		List<String> l =new ArrayList<String>();
		 String str_name = in.nextLine();
	     String []name_str = str_name.split(" ");
	     int max=0;
		for(int i=0;i<name_str.length;i++)
		{
			int count=0;
			for(int j=0;j<name_str.length;j++)
			{
				if(i==j)continue;
				if(name_str[i].equals(name_str[j]))
				{
					count++;
				}
			}
			if(count>max)
				max=count;
		}
		for(int i=0;i<name_str.length;i++)
		{
			int count=0;
			for(int j=0;j<name_str.length;j++)
			{
				if(i==j)continue;
				if(name_str[i].equals(name_str[j]))
				{
					count++;
				}
			}
			if(count==max&&!l.contains(name_str[i]))
				{
					l.add(name_str[i]);
					System.out.println(name_str[i]);
				}
		}

	}

}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值