根据教师的花名册,找到出勤最多的人。
输入格式:
出勤记录单行给出,数据直接使用空格分割。
输出格式:
单行输出(若有多人,人名直接使用空格分割,结尾处没有空格)。
输入样例:
在这里给出一组输入。例如:
zs ls ww ml zs ls ml zs ww
输出样例:
在这里给出相应的输出。例如:
zs
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
List<String> l =new ArrayList<String>();
String str_name = in.nextLine();
String []name_str = str_name.split(" ");
int max=0;
for(int i=0;i<name_str.length;i++)
{
int count=0;
for(int j=0;j<name_str.length;j++)
{
if(i==j)continue;
if(name_str[i].equals(name_str[j]))
{
count++;
}
}
if(count>max)
max=count;
}
for(int i=0;i<name_str.length;i++)
{
int count=0;
for(int j=0;j<name_str.length;j++)
{
if(i==j)continue;
if(name_str[i].equals(name_str[j]))
{
count++;
}
}
if(count==max&&!l.contains(name_str[i]))
{
l.add(name_str[i]);
System.out.println(name_str[i]);
}
}
}
}