7-5 找到出勤最多的人-hebust (25 分)

7-5 找到出勤最多的人-hebust (25 分)

根据教师的花名册,找到出勤最多的人。

输入格式:

出勤记录单行给出,数据直接使用空格分割。

输出格式:

单行输出(若有多人,人名直接使用空格分割,结尾处没有空格)。

输入样例:

在这里给出一组输入。例如:

zs ls ww ml zs ls ml zs ww

输出样例:

在这里给出相应的输出。例如:

zs

代码

import java.util.*;

public class Main {

    private static Object getKey(HashMap<String, Integer> hmap, Integer value) {
        LinkedList<String> key = new LinkedList<>();
        for (HashMap.Entry<String, Integer> entry : hmap.entrySet()) {
            if (value.equals(entry.getValue())) {
                key.add(entry.getKey());
            }

        }
        return key;
    }

    private static Object getMaxValue(Map<String, Integer> map) {
        if (map.size() == 0)
            return null;
        Collection<Integer> c = map.values();
        Object[] obj = c.toArray();
        Arrays.sort(obj);
        return obj[obj.length - 1];

    }


    public static void main(String[] args) {
        Scanner scan = new Scanner(System.in);
        HashMap<String, Integer> hmap = new HashMap<String, Integer>();
        String str = scan.nextLine();
        String[] name = str.split(" ");

        for (String s : name) {
            hmap.put(s, 0);
        }

        for (String s : name) {
            int value = hmap.get(s) + 1;
            hmap.put(s, value);
        }
//         System.out.println(hmap);

        int max_num = (int) getMaxValue(hmap);

        LinkedList<String> skey = (LinkedList<String>) getKey(hmap, max_num);

        for (int i = 0; i < skey.size(); i++) {
            if (i == 0) {
                System.out.print(skey.get(i));
            } else {
                System.out.print(" " + skey.get(i));

            }
        }
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值