找到出勤最多的人

根据教师的花名册,找到出勤最多的人。

输入格式:
出勤记录单行给出,数据直接使用空格分割。

输出格式:
单行输出(若有多人,人名直接使用空格分割,结尾处没有空格)。

输入样例:
在这里给出一组输入。例如:

zs ls ww ml zs ls ml zs ww
输出样例:
在这里给出相应的输出。例如:

zs

 

代码

import java.util.*;

 

class Main{

    public static void main(String[] args) {

       Scanner cin = new Scanner(System.in);

       Map<String, Integer> map = new TreeMap();

       TreeSet ts = new TreeSet();

       int max = 0;

 

       String str_name = cin.nextLine();

       String []name_str = str_name.split(" ");

 

       for( int i = 0; i < name_str.length; i ++ ){

           int t = ts.size();

           ts.add(name_str[i]);

           if( t == ts.size() ){ // 表示有重复

               if ( map.get(name_str[i]) + 1 > max){

                   max = map.get(name_str[i]) + 1;

               }

               map.put( name_str[i], map.get(name_str[i]) + 1); // 更新map中的值

           }

           else{

               map.put(name_str[i], 1 );

           }

       }

       String []cnt_name_people = new String[ts.size()];

       int cnt = 0;

       for( Map.Entry<String, Integer> entry: map.entrySet()){

           String key = entry.getKey();

           int value = entry.getValue();

 

           if( max == 0){// 全部出勤1次,特殊情况

               cnt_name_people[cnt ++ ] = key;

           }

           else if( value == max ){

                cnt_name_people[cnt ++ ] = key;

           }

       }

       for( int i = 0; i < cnt - 1; i ++ ){

           System.out.print(cnt_name_people[i] + " ");

       }

        System.out.println(cnt_name_people[cnt -1 ]);

       cin.close();

    }

}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值