[算法笔记]PAT 1030 Travel Plan

[算法笔记]PAT 1030 Travel Plan

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805464397627392

题目

1030 Travel Plan

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

代码长度限制 16 KB

时间限制 400 ms

内存限制 64 MB

分析

  1. 最短路径->Dijkstra模板
  2. 输出路径->DFS

代码

基于《算法笔记》

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int MAXV = 510;
const int INF = 1000000000;

int n,m,st,ed,G[MAXV][MAXV],weight[MAXV][MAXV];
int d[MAXV],w[MAXV],num[MAXV];
bool vis[MAXV] = {false}; 



//模板D

void D(int s)
{
	fill(d,d+MAXV,INF);
	fill(w,w+MAXV,INF);
	
	for(int i=0;i<n;i++)num[i] = i;
	
	memset(num,0,sizeof(num));
	memset(w,0,sizeof(w));
	
	d[s] = 0;
	w[s] = 0;
	
	
	for(int i=0;i<n;i++)
	{
		int u = -1,MIN = INF;
		for(int j=0;j<n;j++)
		{
			if(vis[j]==false && d[j]<MIN)
			{
				u=j;
				MIN = d[j];
			}
		}
		if(u==-1) return;
		vis[u] = true;
		for(int v=0;v<n;v++)
		{
			if(vis[v]==false && G[u][v] != INF)
			{
				if(d[u]+G[u][v]<d[v])
				{
					//raolu
					d[v] = d[u] + G[u][v];
					w[v] = w[u] + weight[u][v];
					num[v] = u;
					
				}
				else if(d[u]+G[u][v]==d[v])
				{
					
					if(w[u]+weight[u][v]<w[v])
					{
						//注意不要把uv看错 
						w[v] = w[u] + weight[u][v];
						num[v] = u;
					}
				
				}
			}
		}
	}
} 

void DFS(int v)
{
	//溯回函数
	if(v==st)
	{
		printf("%d ",v);
		return ;	
	} 
	DFS(num[v]);
	printf("%d ",v);
}

int main()
{
	scanf("%d%d%d%d",&n,&m,&st,&ed); 
	int u,v;
	fill(G[0],G[0]+MAXV*MAXV,INF);
	for(int i=0;i<m;i++)
	{
		scanf("%d%d",&u,&v);
		scanf("%d%d",&G[u][v],&weight[u][v]);
		G[v][u] = G[u][v];
		weight[v][u] = weight[u][v];
	}
	D(st);
	DFS(ed);
	printf("%d %d\n",d[ed],w[ed]);
	return 0;
}

小结

Dijkstra模板好用捏。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值