Codeup100000622问题 B: Freckles

题目描述:

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad’s back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley’s engagement falls through.
Consider Dick’s back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

输入:

The first line contains 0 < n ≤ 100 0 < n \le 100 0<n100, the number of freckles on Dick’s back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

输出:

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

样例输入:

3
2723.62 7940.81
8242.67 11395.00
4935.54 6761.32
9
10519.52 11593.66
12102.35 2453.15
7235.61 10010.83
211.13 4283.23
5135.06 1287.85
2337.48 2075.61
6279.72 13928.13
65.79 1677.86
5324.26 125.56
0

样例输出:

8199.56
32713.73

说明:

此题没AC主要是测试用例2,此代码牛客网AC,但是这里的测试用例2没有四舍五入

实现代码:

#include<cstdio>
#include<algorithm>
#include<math.h>
using namespace std;

const int maxv = 100 + 10;
const int maxe = 5000;

struct point {
    double x;
    double y;
} P[maxv];

struct Edge {
    int i;
    int j;
    double dis;
} E[maxe];

bool cmp(Edge a, Edge b) {
    return a.dis < b.dis;
}

int father[maxv];

int findFather(int x) {
    int a = x;
    while(x != father[x]) {
        x = father[x];
    }
    while(a != father[a]) {
        int z = a;
        a = father[a];
        father[z] = x;
    }
    return x;
}

double kruscal(int n, int m) {
    double ans = 0;
    int numEdge = 0;
    for(int i = 0; i < n; i++) {
        father[i] = i;
    }
    sort(E, E + m, cmp);
    for(int i = 0; i < m; i++) {
        int faU = findFather(E[i].i);
        int faV = findFather(E[i].j);
        if(faU != faV) {
            father[faU] = faV;
            ans += E[i].dis;
            numEdge++;
        }
    }
    if(numEdge != n - 1) {
        return -1;
    } else {
        return ans;
    }
}

int main() {
    int n;
    int x, y;
    while(scanf("%d", &n) != EOF) {
        if(n == 0) {
            break;
        }
        for(int i = 0; i < n; i++) {
            scanf("%lf%lf", &P[i].x, &P[i].y);
        }
        int m = 0;
        for(int i = 0; i < n; i++) {
            for(int j = i + 1; j < n; j++) {
                E[m].i = i;
                E[m].j = j;
                E[m].dis = sqrt(pow(P[i].x - P[j].x, 2) + pow(P[i].y - P[j].y, 2));
                m++;
            }
        }
        printf("%.2f\n", kruscal(n, m));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值