codeup问题 B: Freckles

题目描述

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad’s back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley’s engagement falls through.
Consider Dick’s back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.
输入

The first line contains 0 < n <= 100, the number of freckles on Dick’s back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.
输出

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.
样例输入 Copy

3
2723.62 7940.81
8242.67 11395.00
4935.54 6761.32
9
10519.52 11593.66
12102.35 2453.15
7235.61 10010.83
211.13 4283.23
5135.06 1287.85
2337.48 2075.61
6279.72 13928.13
65.79 1677.86
5324.26 125.56
0

样例输出 Copy

8199.56
32713.73

题目大意:给出n个点的坐标(x,y)求出能连接出这些点的最小生成树。
思路:kruskal算法,算出每两个点之间边的距离,并编号。

#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <string>
#include <memory.h>
#include <set>
#include <stack>
#include <queue>
#include <unordered_map>
#include <iomanip>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 5010;
struct node {
	double x, y;
}nn[110];
struct ss {
	int u, v;
	double cost;
}s[maxn];
bool cmp(ss a, ss b) {
	return a.cost < b.cost;
}
int father[maxn];
int findfather(int x) {
	int a = x;
	while (x != father[x]) {
		x = father[x];
	}
	while (a != father[a]) {
		int z = a;
		a = father[a];
		father[z] = x;
	}
	return x;
}
double kruskal(int n, int m) {
	double ans = 0;
	int snum = 0;
	for (int i = 0; i < m; i++) {
		father[i] = i;
	}
	sort(s, s + m, cmp);
	for (int i = 0; i < m; i++) {
		int fau = findfather(s[i].u), fav = findfather(s[i].v);
		if (fau != fav) {
			father[fau] = fav;
			snum++;
			ans += s[i].cost;
			if (snum == n - 1)
				break;
		}
	}
	if (snum == n - 1)
		return ans;
	else
		return -1;
}

int main() {
	int n;
	while (cin >> n) {
		if (n == 0)
			break;
		for (int i = 0; i < n; i++) {
			cin >> nn[i].x >> nn[i].y;
		}
		int count = 0;
		for (int i = 0; i < n; i++) {
			for (int j = i + 1; j < n; j++) {
				s[count].u = i;
				s[count].v = j;
				s[count++].cost = sqrt((nn[i].x - nn[j].x)*(nn[i].x - nn[j].x) + (nn[i].y - nn[j].y)*(nn[i].y - nn[j].y));
			}
		}
		double ans = kruskal(n, count);
		printf("%.2lf\n", ans);
	}
	return 0;
}

这份代码答案错误50,原因是因为第二组测试样例32713.73,kruskal算法算出保留两位小数是32713.74,应该是题目给的测试样例有问题。这题在牛客网上能AC。若发现代码有错误望指正。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值