DS||Simply Syntax

题目描述
In the land of Hedonia the official language is Hedonian. A Hedonian professor had noticed that many of her students still did not master the syntax of Hedonian well. Tired of correcting the many syntactical mistakes, she decided to challenge the students and asked them to write a program that could check the syntactical correctness of any sentence they wrote. Similar to the nature of Hedonians, the syntax of Hedonian is also pleasantly simple. Here are the rules: 0. The only characters in the language are the characters p through z and N, C, D, E, and I. 1. Every character from p through z is a correct sentence. 2. If s is a correct sentence, then so is Ns. 3. If s and t are correct sentences, then so are Cst, Dst, Est, and Ist. 4. Rules 0. to 3. are the only rules to determine the syntactical correctness of a sentence. You are asked to write a program that checks if sentences satisfy the syntax rules given in Rule 0. - Rule 4.
输入
The input consists of a number of sentences consisting only of characters p through z and N, C, D, E, and I. Each sentence is ended by a new-line character. The collection of sentences is terminated by the end-of-file character. If necessary, you may assume that each sentence has at most 256 characters and at least 1 character.
输出
The output consists of the answers YES for each well-formed sentence and NO for each not-well-formed sentence. The answers are given in the same order as the sentences. Each answer is followed by a new-line character, and the list of answers is followed by an end-of-file character.
样例输入 Copy
Cp
Isz
NIsz
Cqpq

样例输出 Copy
NO
YES
YES
NO

#include <cstdio>
#include <cstring> 
char s[300];
int main()
{ while(scanf("%s",s)!=EOF) 
{  int size=strlen(s);
  size--;
  int num=0;
  int i=size;
  while(i>=0) 
  {   if(s[i]>='p'&&s[i]<='z')
  {    num++;   } 
  else  
  {    
   if(s[i]=='C'||s[i]=='D'||s[i]=='E'||s[i]=='I') 
   {     num--;
   if(num<1)
   {     
    break;   
   }   
   }   
   else   
   {    
    if(s[i]=='N')
    {      
     if(num<1)
     {       
      break;     
     }     
    }     
    else
    {  
     num=-1; 
     break;  
    }   
   }  
  }  
  i--; 
  } 
  if(num==1)
  {   
   printf("YES\n"); 
 } 
  else 
  {   
   printf("NO\n"); 
 }
 }
 return 0;} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值