PAT (Advanced Level) 1065 A+B and C (20)

Given three integers A, B and C in [-2^63^, 2^63^], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B&gtC, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false
C++:
#include<cstdio>
int main(){
	int T;
	bool flag; //判断正误 
	long long A,B,C,sum;
	do
	scanf("%d",&T);
	while(T>10||T<=0);	
	for(int i=0;i<T;i++){
		scanf("%lld%lld%lld",&A,&B,&C);
		sum = A+B;
		if(A>0 && B>0 && sum<0)
		    flag = true;
		else if(A<0 && B<0 && sum>=0)
		    flag = false;
		else if(sum>C)
	            flag = true;
		else
		    flag = false;
	
		if(flag == true)
			printf("Case #%d: true\n",i+1);
		else
			printf("Case #%d: false\n",i+1);	
		}
			
	return 0;	
}	
注:

由于A、B、C的数值范围大于int型,所以选择long long范围,但是A+B必然会导致溢出,所以这时需要对是否溢出做一个判断。

按照计算机组成原理中指出,如果两个正数之和等于负数,或者两个负数之和等于正数,就是溢出。本题中正数溢出一定比C大,负数溢出一定比C小。其他情况则可以直接使用A+B是否大于C判断。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值