2119 数据结构实验之链表四:有序链表的归并

数据结构实验之链表四:有序链表的归并

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
Example Input
6 5
1 23 26 45 66 99
14 21 28 50 100
Example Output
1 14 21 23 26 28 45 50 66 99 100
Hint
不得使用数组! 
#include <bits/stdc++.h>
using namespace std;

typedef struct node
{
    int date;
    struct node *next;
}Lnode;

Lnode *creat(int n)//建表 输入
{
    Lnode *p,*q,*head;
    head = new node;
    head -> next = NULL;
    q = head;
    while(n--)
    {
        p = new node;
        p -> next = NULL;
        scanf("%d",&p->date);
        q ->next = p;
        q = p;
    }
    return head;
}

void output( Lnode *head) //输出
{
    Lnode *q;
    q = head ->next;
    cout << q ->date;
    while(q->next)
    {
        cout << " " << q ->next ->date;
        q = q ->next;
    }
    cout << endl;
}

Lnode *change(Lnode * head1,Lnode * head2) //归并
{
    Lnode *p1, *p2, *q;
    p1 = head1 ->next;
    p2 = head2 ->next;
    q = head1;
    while(p1&&p2)                  //p1p2 其一遍历完便会break出来
    {
        if(p1->date < p2->date)
        {
            q->next = p1;
            q = p1;
            p1 = p1 ->next;
        }
        else
        {
            q->next = p2;
            q = p2;
            p2 = p2 ->next;
        }
    }
    if(p1)               //p1!=0 即p1在while中未遍历完全 将p1剩余全部接上
    {
        q ->next = p1;
    }
    if(p2)              //p2!=0 即p2在while中未遍历完全
    {
        q ->next = p2;
    }
    return head1;
}

int main()
{
    int n, m;
    Lnode *head1,*head2;
    cin >> n >> m;
    head1 = creat(n);
    head2 = creat(m);
    head1 = change(head1,head2);
    output(head1);
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值