uvalive6952 - Cent Sa dp

6952 Cent Savings
To host a regional contest like NWERC a lot of preparation
is necessary: organizing rooms and computers,
making a good problem set, inviting contestants, designing
T-shirts, booking hotel rooms and so on. I am
responsible for going shopping in the supermarket.
When I get to the cash register, I put all my n
items on the conveyor belt and wait until all the other
customers in the queue in front of me are served.
While waiting, I realize that this supermarket recently
started to round the total price of a purchase
to the nearest multiple of 10 cents (with 5 cents being
rounded upwards). For example, 94 cents are
rounded to 90 cents, while 95 are rounded to 100.
It is possible to divide my purchase into groups
and to pay for the parts separately. I managed to find d dividers to divide my purchase in up to d + 1
groups. I wonder where to place the dividers to minimize the total cost of my purchase. As I am
running out of time, I do not want to rearrange items on the belt.
Input
The input file contains several test cases, each of them as described below.
The input consists of:
• one line with two integers n (1 ≤ n ≤ 2000) and d (1 ≤ d ≤ 20), the number of items and the
number of available dividers;
• one line with n integers p1, …, pn (1 ≤ pi ≤ 10000 for 1 ≤ i ≤ n), the prices of the items in cents.
The prices are given in the same order as the items appear on the belt.
Output
For each test case, output the minimum amount of money needed to buy all the items, using up to d
dividers.
Sample Input
5 1
13 21 55 60 42
5 2
1 1 1 1 1
Sample Output
190
0**
题意:

用最多d个划分d+1个组使各组之和最小,和会四舍五入,如若和为15则付20,和为114则付110

思路:
dp[i][k+1],即在i点划分为第k+1组的最小和,就会发现dp[i][k+1]=dp[j][k]+(sum[j]-sum[i])/10*10或(sum[j]-sum[j])/10*10+10,(判断条件就是如果(sum[j]-sum[i])%10<5就是前者,否则是后者)
j为前i-1位,dp[j][k]即j位划分为第k组的最小和

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int inf=99999999;
int p[2005];
int sum[2005];
int dp[2005][25];
int main()
{
    int n,d;
    while(scanf("%d%d",&n,&d)!=-1)
    {
        memset(sum,0,sizeof sum);
        for(int i=1;i<=n;i++){
            scanf("%d",&p[i]);
            sum[i]=sum[i-1]+p[i];
        }
        memset(dp,0,sizeof dp);
        for(int i=0;i<=n;i++)
            for(int j=0;j<=d+1;j++)
            dp[i][j]=inf;
        for(int i=1;i<=n;i++){
            int temp=sum[i]%10;
            if(temp>=5)
           dp[i][1]=sum[i]/10*10+10;
            else
                dp[i][1]=sum[i]/10*10;
        }
        for(int k=1;k<=d;k++)
        for(int i=k;i<=n;i++){
           for(int j=0;j<i;j++){
               int res=(sum[i]-sum[j]);
               if(res%10>=5) res=res/10*10+10;
               else res=res/10*10;
               //printf("res=%d\n",res);
               dp[i][k+1]=min(dp[j][k]+res,dp[i][k+1]);
               /*if(dp[i][k]>=inf)
                   puts("1-------");
               else
               printf("%d %d %d dp[j][k]=%d dp[i][k+1]=%d\n",k,i,j,dp[j][k],dp[i][k+1]);*/
           }
        }
        int ans=dp[n][d+1];
       for(int i=1;i<=d+1;i++){
            ans=min(dp[n][i],ans);
        }
        printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值