hdu 1071 The area 高数积分求面积~~~~小水题~~

18 篇文章 0 订阅

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8190    Accepted Submission(s): 5748


Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.


 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

Sample Input
  
  
2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222
 

Sample Output
  
  
33.33 40.69
Hint
For float may be not accurate enough, please use double instead of float.
 
主要就是利用高数中的积分知识~
代码:
#include <stdio.h>
#include <math.h>
#define deta 0.01
struct Point{
	double x , y ;
};
int main()
{
	int t ;
	scanf("%d",&t);
	while(t--)
	{
		Point p1,p2,p3;
		scanf("%lf%lf",&p1.x,&p1.y) ;
		scanf("%lf%lf",&p2.x,&p2.y) ;
		scanf("%lf%lf",&p3.x,&p3.y) ;
		double k = (p3.y-p2.y)/(p3.x-p2.x) ;
		if(p2.x>p3.x)
		{
			Point t = p2;
			p2 = p3 ;
			p3 = t ;
		}
		double A,C;
		C = p1.y ;
		A = (p3.y-C)/((p3.x-p1.x)*(p3.x-p1.x)) ;
		double ans = 0.0 ;
		for(double i = p2.x+deta ; i <= p3.x ; i+=deta)
		{
			double y = fabs(A*(i-p1.x)*(i-p1.x)+C-k*(i-p2.x)-p2.y) ;
			ans += y*deta ;
		}
		printf("%.2lf\n",ans) ;
	}
	return 0 ;
}

与君共勉
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值