hdu 1546 Idiomatic Phrases Game 最短路

154 篇文章 1 订阅
50 篇文章 0 订阅

Idiomatic Phrases Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2283    Accepted Submission(s): 742


Problem Description
Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.
 

Input
The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.
 

Output
One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.
 

Sample Input
  
  
5 5 12345978ABCD2341 5 23415608ACBD3412 7 34125678AEFD4123 15 23415673ACC34123 4 41235673FBCD2156 2 20 12345678ABCD 30 DCBF5432167D 0
 

Sample Output
  
  
17 -1
 其实弄懂这道题后,就会发现。。水题一枚。

给出n个“成语”, 这写成语至少由3个“汉字”组成,所谓的“汉字”,是指4个连续的16进制数字(1~9, A~F)。 

以第一个成语作为起点,最后一个作为终点, 需要找出一个序列,这个序列的前一个成语的最后一个“汉字”与后一个成语的第一个“汉字”是相同的,求最少花费时间。

代码:

#include <stdio.h>
#include <string.h>
#define INF 1000000000
struct Node{
	char s[5],e[5] ;
	int t ;
}list[1100];
int graph[1100][1100] , dis[1100];

void dijkstra(int n)
{
	bool visited[1100] ;
	for(int i = 0 ; i < n ; ++i)
	{
		dis[i] = graph[0][i] ;
		visited[i] = false ;
	}
	dis[0] = 0 ;
	visited[0] = true ;
	for(int i = 1 ; i < n ; ++i)
	{
		int min = INF , index = -1 ;
		for(int j = 0 ; j < n ; ++j)
		{
			if(!visited[j] && min>dis[j])
			{
				index = j ;
				min = dis[j] ;
			}
		}
		if(index == -1)
		{
			return ;
		}
		visited[index] = true ;
		for(int j = 0 ; j < n ; ++j)
		{
			if(!visited[j] && dis[j]>min+graph[index][j])
			{
				dis[j] = min+graph[index][j] ;
			}
		}
	}
}

int main()
{
	int n ;
	while(scanf("%d",&n) && n)
	{
		for(int i = 0 ; i < n ; ++i)
		{
			for(int j = 0 ; j < n ; ++j)
			{
				graph[i][j] = INF ;
			}
		}
		char str[110] ;
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%d%s",&list[i].t,str) ;
			for(int j = 0 ; j < 4 ; ++j)
			{
				list[i].s[j] = str[j] ; 
			}
			list[i].s[4] = '\0' ;
			int k = 0 ;
			for(int j = strlen(str)-4 ; j < strlen(str) ; ++j)
			{
				list[i].e[k++] = str[j] ; 
			}
			list[i].e[4] = '\0' ;
		}
		for(int i = 0 ; i < n-1 ; ++i)
		{
			for(int j = 0 ; j < n ; ++j)
			{
				if(strcmp(list[i].e,list[j].s)==0)
				{
					graph[i][j] = list[i].t ;
				}
			}
		}
		dijkstra(n) ;
		if(dis[n-1] == INF)
			puts("-1") ;
		else
			printf("%d\n",dis[n-1]) ;
	}
	return 0 ;
}

与君共勉

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值