HDU 1546 (最短路 Dijkstra算法)

题目:

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary. 

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case. 

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

Sample Input

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

Sample Output

17
-1

题目大意:

成语接龙游戏,多组输入,输入格式为:   第一行是成语个数n,后面n行:“当前成语出发找下一个成语” 的权值(题目描述为 时间),以及后面的汉字(以16进制表示,最少三个汉字),首尾相连找从1连到n的最短路。

解题报告:

遍历每两个成语,若A成语可找到B成语,则用数组a[A][B]记录花费的时间。

注意:写代码的时候,能降低时间复杂度,就降低时间复杂度,否则容易超时。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<vector>
#define Max 99999999
#define ll long long
using namespace std;
int n,ta[1005][1005],dis[1005];
int val[1005],length[1005];
char g[1005][100];//可以用这个来存多个字符串,但是有点耗空间 
void init()
{
    int i,j;
    for(i=0;i<=n;i++)
    {
           ta[i][i]=0;
        for(j=0;j<i;j++)
        {
            ta[j][i]=ta[i][j]=Max;
        }
    }
}
void dijk()
{
    int mp[1005]={0};
    int i,j,k;
    for(i=1;i<=n;i++)
    {
        dis[i]=ta[1][i];
    }
    mp[1]=1;
    for(i=1;i<=n;i++)
    {
        int ans=Max;
        for(j=1;j<=n;j++)
        {
            if(ans>dis[j]&&mp[j]==0)
            {
                ans=dis[j];
                k=j;
            }
        }
        mp[k]=1;
        if(k==n)return;
        for(j=1;j<=n;j++)
        {
            if(mp[j]==0&&dis[j]>dis[k]+ta[k][j])
            {
                dis[j]=dis[k]+ta[k][j];
            }
        }
    }
}
bool ok(int i,int j) {
    if(g[i][length[i]-1] == g[j][3] && g[i][length[i]-2] == g[j][2]&& g[i][length[i]-3] ==g[j][1] && g[i][length[i]-4]== g[j][0]) {
        return true;
    }
    return false;
}//判断两成语的关系时,可用这样判断,而无需用循环,可以降低时间复杂度。 
int main()
{
    while(1)
    {
        scanf("%d",&n);
        if(n==0)break;
        int i,j,k,l,m,s,t;
        init();
        for(i=1;i<=n;i++)
        {
            scanf("%d",&val[i]);
            getchar();
            scanf("%s",g[i] );
            length[i]=strlen(g[i]);//将每个字符串长度记录在一个数组里面 
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(ok(i,j))ta[i][j]=val[i] ;//向ok()函数传参数时,传下标,而不要传字符串,这样更快 
            }
        }
//        			s=g[i].a.size() ;
//			for(j=1;j<i;j++)
//			{
//				
//				t=g[j].a.size() ;//用一次求一次字符串长度太耗时 
//				if(ok(i,s,j,t))ta[i][j]=g[i].b ;
//				if(ok(j,t,i,s))ta[j][i]=g[j].b ;
//				for(k=0,l=t-4;l<=t-1&&k<=3;k++,l++)
//				{
//					if(g[i].a[k]!=g[j].a[l]) break;//用循环判断两个成语关系会提高复杂度 
//				}
//				if(k>3){
//				    ta[j][i]=g[j].b;continue; 
//				}
//				for(k=s-4,l=0;k<=s-1&&l<=3;k++,l++)
//				{
//					if(g[i].a[k]!=g[j].a[l])break;
//				}
//				if(l>3)ta[i][j]=g[i].b ;
//			}
        dijk();
        if(dis[n]==Max)
            printf("-1\n");
        else printf("%d\n",dis[n]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值