An Easy Task HDU1076

An Easy Task
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16243 Accepted Submission(s): 10381

Problem Description

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).

Output

For each test case, you should output the Nth leap year from year Y.

Sample Input

3
2005 25
1855 12
2004 10000

Sample Output

2108
1904
43236

Hint

We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.

1,这个想明白了很简单,闰年没400年一个周期,从一个最近的闰年开始,每400年中就有97个闰年,让N对400取余后剩下的闰年数用循环求出剩下的年数
2,注意找到最近的一个闰年后,要把N值减一
3,注意不能使用蛮力法,会超时

#include<iostream>
#include<cstdio>

using namespace std;

int main()
{
    int T,N,Y;
    int i,j;


    cin >> T;
    while(T--)
    {
        scanf("%d%d",&Y,&N);
        while(!(Y % 400 == 0 || Y % 4 == 0 && Y % 100 != 0))
            Y++;//找到最近的闰年
        N--;
        if(N > 97)
        {
            i = N / 97;
            N = N % 97;
            Y += i * 400;
        }//跳过周期部分,避免使用蛮力法时TLE
        while(N--)
        {
            Y+=4;
            if(!(Y % 400 == 0 || Y % 4 == 0 && Y % 100 != 0)) Y+=4;
        }
        cout << Y << endl;
    }


    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值