HDU_5327_Olympiad

Olympiad

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 428    Accepted Submission(s): 308


Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (ab) . Please be fast to get the gold medal!
 


Input
The first line of the input is a single integer T (T1000) , indicating the number of testcases.

For each test case, there are two numbers a and b , as described in the statement. It is guaranteed that 1ab100000 .
 


Output
For each testcase, print one line indicating the answer.
 


Sample Input
  
  
2 1 10 1 1000
 


Sample Output
  
  
10 738
 


Author
XJZX
 


Source
 


Recommend
wange2014


题目描述有重复数字的数不是美丽的数

求某区间中美丽的数的个数

预处理下全部的数字,像筛法求素数一样即可

#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;

const int M=100005;
int num[M];
int nn[7];

int main()
{
    int t;
    int a,b;
    scanf("%d",&t);
    for(int i=10;i<M;i++)
    {
        if(num[i])
            continue;
        int ti=i;
        int p=0;
        int f=1;
        int ws=0;
        while(ti>0)
        {
            nn[p]=ti%10;

            ti/=10;
            for(int j=0;j<p;j++)
                if(nn[j]==nn[p])
                {
                    num[i]=1;
                    f=0;
                    break;
                }
            p++;
            ws++;
        }
        if(!f)
        {
            int dn=pow(10,ws);
            for(int j=dn+i;j+i<M;j+=dn)
                num[j]=1;
        }
    }

    while(t--)
    {
        int co=0;
        scanf("%d%d",&a,&b);
        for(int i=a;i<=b;i++)
            if(!num[i])
                co++;
        printf("%d\n",co);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值