2015多校联合第四场hdu5327Olympiad 递推

Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval  [a,b] (ab) . Please be fast to get the gold medal!
 

Input
The first line of the input is a single integer  T (T1000) , indicating the number of testcases. 

For each test case, there are two numbers  a  and  b , as described in the statement. It is guaranteed that  1ab100000 .
 

Output
For each testcase, print one line indicating the answer. 
 

Sample Input
  
  
2 1 10 1 1000
 

Sample Output
  
  
10 738
 

最开始的思路是特别暴力的逐个试,超时,搜题解,有这么做的,更奇葩的是人家用cin cout AC了,我是scanf 把他(按比例来说更大些)的代码换成scanf printf超时了……什么鬼,(我为了拉低杭电AC率做出了卓越贡献生气

自己找别的思路,可能有公式?推导半天没有头绪,始终觉得预处理可能会好些 果不其然 而且是0ms的代码 太优美了~

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
bool num[10],flag;
int t,a,b,m,n,f[100005];
bool check(int x)
{
    memset(num,0,sizeof(num));
    for(int i=0;x;x/=10)
    {
        if(num[x%10]) return 0;
        else num[x%10]=1;
    }
    return 1;
}
void init()
{
    for(int i=1;i<=100000;i++)
        f[i]=f[i-1]+check(i);//这里的递推好赞
}
int main()
{
    init();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        printf("%d\n",f[m]-f[n-1]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值