HDU-1698 Just a Hook(区间更新)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22759    Accepted Submission(s): 11383


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 

Source
 

Recommend
wangye   |   We have carefully selected several similar problems for you:   1542  1255  1828  1540  3397 
 


/*线段树(区间更新):
 *用一个数组来标记每个节点的状态,即该区间每个单位的价值
 *线段树的每个节点表示一个区间中的价值总和
 *每次都只将数据更新到符合操作的区间,不更新到叶节点,避免超时
*/
#include <iostream>
#include <cstdio>
#include <math.h>
#define N 100005
#define lson l,mid,rt << 1
#define rson mid + 1,r,rt << 1 | 1
using namespace std;

int Tree[N << 2];
int Col[N << 2];

void PushUp(int rt)//向上传递区间价值之和
{
    Tree[rt] = Tree[rt << 1] + Tree[rt << 1 | 1];
}
void PushDown(int rt,int m)//向下更新节点状态
{
    if(Col[rt])//如果当前节点已经被标记过,就需要将之前更新的结果传递给子节点,不然下次更新会覆盖掉当前节点的前一次更新
    {
        Col[rt << 1] = Col[rt << 1 | 1] = Col[rt];//将标记传递给子节点
        Tree[rt <<1] =(m -( m >> 1) )* Col[rt];//计算每个节点的价值和
        Tree[rt << 1 | 1] =( m >> 1) * Col[rt ];//注意这个m代表的是当前节点的区间长度,而 m-m>>1= r-l+1-(r-l+1)/2 = (r+l)/2-l+1;数学上不成立,但是这里成立,要考虑整数相除结果是整数
        Col[rt] = 0;//当前节点状态初始化
    }
}
void Build(int l,int r,int rt)
{
    Col[rt] = 0;
    Tree[rt] = 1;
    if(l == r)
        return;
    int mid = (l + r ) >> 1;
    Build(lson);
    Build(rson);
    PushUp(rt);
}
void Update(int ll,int rr,int c,int l,int r,int rt)
{
    if(ll <= l && r <= rr)
    {
        Col[rt] = c;
        Tree[rt]  = (r - l + 1 )  * c;
        return;
    }
    int mid = (l + r ) >> 1;
    PushDown(rt,r - l +1);//当前节点不是要查找的区间,于是将当前节点的更新情况传递给子节点
    if(ll <= mid)
        Update(ll,rr,c,lson);
    if(rr > mid)
        Update(ll,rr,c,rson);
    PushUp(rt);
}
int main()
{
   //freopen("FileIn.txt","r",stdin);
    //freopen("FileOut.txt","w",stdout);

    int T,n,m;
    scanf("%d",&T);
    for(int Case = 1; Case <= T; Case++)
    {
        scanf("%d%d",&n,&m);
        Build(1,n,1);
        while(m--)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            Update(a,b,c,1,n,1);
        }
        printf("Case %d: The total value of the hook is %d.\n",Case,Tree[1]);
    }

   //fclose(stdin);
    //fclose(stdout);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值