hduoj 5327 Olympiad (一维前缀和)

Problem Description

You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (a≤b). Please be fast to get the gold medal!

Input

The first line of the input is a single integer T (T≤1000), indicating the number of testcases.
For each test case, there are two numbers a and b, as described in the statement. It is guaranteed that 1≤a≤b≤100000.

Output

For each testcase, print one line indicating the answer.

Sample Input

2
1 10
1 1000

Sample Output

10
738

思路:预处理+一维前缀和
#include<iostream>
#include<cstring>
using namespace std;
const int MAXN = 1e6 + 50;
int n,a,b;
int sum[MAXN];
bool vis[10];

bool isBeautiful(int x){
	memset(vis,0,sizeof(vis));
	while(x){
		int cur = x%10;
		if(!vis[cur]) vis[cur] = true;
		else return false;
		x /= 10;
	}
	return true;
}
void Init(){
	sum[0] = 0;
	for(int i = 1;i < MAXN; i++){
		sum[i] = isBeautiful(i) + sum[i-1];
	}
}
int main(){
	Init();
	cin>>n;
	while(n--){
		cin>>a>>b;
		cout<<sum[b] - sum[a-1]<<endl;
	} 
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值