2018年第三阶段个人训练赛第二场 6586 Problem I: Decrease (Judge ver.)

题目描述

We have a sequence of length N consisting of non-negative integers. Consider performing the following operation on this sequence until the largest element in this sequence becomes N−1 or smaller. (The operation is the same as the one in Problem D.)
Determine the largest element in the sequence (if there is more than one, choose one). Decrease the value of this element by N, and increase each of the other elements by 1.
It can be proved that the largest element in the sequence becomes N−1 or smaller after a finite number of operations.
You are given the sequence ai. Find the number of times we will perform the above operation.

Constraints
2≤N≤50
0≤ai≤1016+1000

 

 

输入

Input is given from Standard Input in the following format:
N
a1 a2 ... aN
 

 

输出

Print the number of times the operation will be performed.

 

样例输入

4
3 3 3 3

 

样例输出

0

Sample Input 1 

3 3 3 3 
Sample Output 1 

Sample Input 2 

1 0 3 
Sample Output 2 

Sample Input 3 

2 2 
Sample Output 3 

Sample Input 4 

27 0 0 0 0 0 0 
Sample Output 4 

Sample Input 5 
10 
1000 193 256 777 0 1 1192 1234567891011 48 425 
Sample Output 5 
1234567894848

题意:给出a1,a2,…,an,每次操作将最大的数减N,其余加1,问进行多少次操作后,该数列最大值<=n-1。 
思路:每次取最大的将其减为n以下,其余加一,直到所有数小于n。

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
    int i;
    long long a[100];
    long long int sum=0;
    for(i=1;i<=n;i++)
    {
        scanf("%lld",&a[i]);
    }
    sort(a+1,a+1+n);
    while(1)
    {
        if(a[n]<n)
        {
            printf("%lld\n",sum);
            break;
        }
        long long x=a[n]/n;
        a[n]=a[n]%n;
        sum+=x;
        for(i=1; i<n; i++)
        {
            a[i]+=x;
        }
        sort(a+1,a+1+n);


    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值