D - Decrease (Contestant ver.)(思维好题)

Problem Statement

We have a sequence of length N consisting of non-negative integers. Consider performing the following operation on this sequence until the largest element in this sequence becomes N−1 or smaller.

Determine the largest element in the sequence (if there is more than one, choose one). Decrease the value of this element by N, and increase each of the other elements by 1.
It can be proved that the largest element in the sequence becomes N−1 or smaller after a finite number of operations.

You are given an integer K. Find an integer sequence ai such that the number of times we will perform the above operation is exactly K. It can be shown that there is always such a sequence under the constraints on input and output in this problem.

Constraints

0≤K≤50×1016
Input

Input is given from Standard Input in the following format:

K
Output

Print a solution in the following format:

N
a1 a2 ... aN
Here, 2≤N≤50 and 0≤ai≤1016+1000 must hold.

Sample Input 1

0
Sample Output 1

4
3 3 3 3
Sample Input 2

1
Sample Output 2

3
1 0 3
Sample Input 3

2
Sample Output 3

2
2 2
The operation will be performed twice: [2, 2] -> [0, 3] -> [1, 1].

Sample Input 4

3
Sample Output 4

7
27 0 0 0 0 0 0
Sample Input 5

1234567894848
Sample Output 5

10
1000 193 256 777 0 1 1192 1234567891011 48 425

代码:
 

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
long long int a[51];
int main()
{
    long long int n;
    while(scanf("%lld",&n)==1)
    {
        memset(a,0,sizeof(a));
        for(long long int i=1;i<=50;i++)
            a[i]=49+n/50;                      //n/50就相当于50个数字每个数字都得要被减(n/50)次50还要加(n/50)次49(因为每个数被减去其他的数就要加一)
 
        long long int m=n%50;                  //多出来的要执行的操作次数;
        long long int j;
        for(int i=1;i<=50;i++) a[i]=a[i]-m;    //根据逆向思维,多出多少次,其他的数字就要减去多少个一;
        for(j=1;j<=m;j++)a[j]+=51;             //因为多出来m次,所以在m个数上加50;
 
        printf("50\n");
        for(int i=1;i<=50;i++)printf("%lld ",a[i]);
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值