poj 3273(二分)区间的最大值

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题意是先给你两个数,一个全部数的个数第二个是要划分的区间,让你求区间的和的最小的那个。。这个二分真是。。学长说反正是求最小最大值一般都是二分。
由于要求的这个数 下界是这些数里面最大的那个,上界是所有数的和,所以就可以用二分了。这个二分没有中途跳出的条件,修改一下,因为大家都知道二分就是找中值,而这种是用第三个变量代表中值,即刚好满足个数,然后围绕这个中值,进行真正边界的上下波动得出所求值,这种二分的难点在于边界的起点终点,第三变量统计的条件。

#include <stdio.h>  
#include <algorithm>  
#include <iostream>  
#include <queue>  
#include <string.h>  
using namespace std;
int n,m;
const int maxn=500110;
int a[maxn];
int main()
{
     while(scanf("%d%d",&n,&m)!=EOF)
     {
        int sum=0;
        int maxi=0;
     for(int i=0;i<n;i++)
     {
        scanf("%d",&a[i]);
        if(a[i]>maxi)
            maxi=a[i];
        sum+=a[i];
     }  
     int l=maxi; //难点,边界的起点终点,统计的条件。
     int r=sum;
     int ans=0;
     int mid=0;
     int num=0;
     int maxm=0;
     while(l<=r)      //当下界小于等于上界的时候
     {
        mid=(l+r)>>1; //求中值
        sum=0;
        ans=1; //一开始必要有一个区间。
        for(int i=0;i<n;i++)
        {
            sum+=a[i];
            if(sum>mid)  //二分的难点和精髓就是找满足的这个条件,实质是求大于这个数的区间有多少个。
            {
                sum=a[i];
                ans++;   //一次大于便有两个区间所以起码是两个
            }
        }
        if(ans<=m)  //如果区间数小于等于需要的区间 那么这个最大值变小。
        {
            maxm=mid; 
            r=mid-1;
        }
        else
            l=mid+1;
     }
     printf("%d\n",maxm);
     }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值