hdu 6085 (bitset区间取值)

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them: 

There are  n n children and  m m kinds of candies. The  i ith child has  Ai Ai dollars and the unit price of the  i ith kind of candy is  Bi Bi. The amount of each kind is infinity. 

Each child has his favorite candy, so he will buy this kind of candies as much as possible and will not buy any candies of other kinds. For example, if this child has  10 10 dollars and the unit price of his favorite candy is  4 4 dollars, then he will buy two candies and go home with  2 2 dollars left. 

Now Yuta has  q q queries, each of them gives a number  k k. For each query, Yuta wants to know the number of the pairs  (i,j)(1in,1jm) (i,j)(1≤i≤n,1≤j≤m) which satisfies if the  i ith child’s favorite candy is the  j jth kind, he will take  k k dollars home. 

To reduce the difficulty, Rikka just need to calculate the answer modulo  2 2

But It is still too difficult for Rikka. Can you help her?
Input
The first line contains a number  t(1t5) t(1≤t≤5), the number of the testcases. 

For each testcase, the first line contains three numbers  n,m,q(1n,m,q50000) n,m,q(1≤n,m,q≤50000)

The second line contains  n n numbers  Ai(1Ai50000) Ai(1≤Ai≤50000) and the third line contains  m mnumbers  Bi(1Bi50000) Bi(1≤Bi≤50000)

Then the fourth line contains  q q numbers  ki(0ki<maxBi) ki(0≤ki<maxBi) , which describes the queries. 

It is guaranteed that  AiAj,BiBj Ai≠Aj,Bi≠Bj for all  ij i≠j.
Output
For each query, print a single line with a single  01 01 digit -- the answer.
Sample Input
1
5 5 5
1 2 3 4 5
1 2 3 4 5
0 1 2 3 4
Sample Output
0
0
0
0
1
 
 
给出数组A和B,问多少对 A%B==ki。数据大小 5e4 考虑n^2/32*log 可以知道的是取模运算。
一个数%B 和%2B 结果相等,考虑到对ki的贡献,只有比ki大的B才会对ki有贡献,我们考虑遍历B.从大到小,然后不断更新B存在的位置(log),然后不断计算这样a%b(比当前b大)==ki的个数,这个只要用减法就可以做到,利用bitset的位运算,bx&(a>>i).count()&1,更方便快捷
 
 
#include <bits/stdc++.h>
using namespace std;
const int N = 50000+5;
bitset<N> a,b,ans,bx;

void solve(int x)
{
	bx.reset();
	for(int i=x;i>=0;i--)
	{
		ans[i]=(bx&(a>>i)).count()&1;
		if(b[i])
		{
			for(int j=0;j<N;j+=i)
				bx.flip(j);
		}
	}
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		a.reset(),b.reset();
		int n,m,q,x,maxt=0;
		scanf("%d%d%d",&n,&m,&q);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&x);
			a.set(x);
		}
		for(int i=1;i<=m;i++)
		{
			scanf("%d",&x);
			b.set(x);
			maxt=max(x,maxt);
		}
		ans.reset();
		solve(maxt);
		while(q--)
		{
			int x;
			scanf("%d",&x);
			puts(ans[x]?"1":"0");
		}
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值