Triangular Sums
时间限制:
3000 ms | 内存限制:
65535 KB
难度:
2
-
描述
-
The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):
X
X X
X X X
X X X X
Write a program to compute the weighted sum of triangular numbers:
W(n) =
SUM[k = 1…n; k * T(k + 1)]
-
输入
-
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.
输出
- For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n. 样例输入
-
4 3 4 5 10
样例输出
-
1 3 45 2 4 105 3 5 210 4 10 2145
来源
-
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
就是直接计算就行了,公式就是W(n) = SUM[k = 1…n; k * T(k + 1)]
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int solve(int x)
{
int i,sum=0;
for(i=1;i<=x;i++)
sum+=i;
return sum;
}
int main()
{
int a,b,c,d,i,j,m,n,t,sum,cot=1;;
scanf("%d",&m);
while(m--)
{
sum=0;
scanf("%d",&a);
for(i=1;i<=a;i++)
sum+=i*solve(i+1);
printf("%d %d %d\n",cot++,a,sum);
}
return 0;
}