YT14-HDU-求1/n的第m位数

Problem Description

Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed

Input

Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)

Output

For each line of input, your program should print a numble on a line,according to the above rules

Sample Input

4 2
5 7
123 123

Sample Output

5
0
8

Author

YBB

Source

HDU 2007-10 Programming Contest_WarmUp

代码如下:

#include <iostream>
using namespace std;
int main()
{
    int n,m,i,s,t;
    while(cin>>n>>m)
    {
        if(m==1)
            cout<<0<<endl;
        else
        {
            s=10;
            for(i=1; i<=m; i++)
            {

                t=s/n;
                s=s%n*10;
            }
            cout<<t<<endl;
        }
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值