YT14-HDU-#是@与.爱情的那堵墙

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

代码如下:

#include <iostream>
using namespace std;
char str1[21][21];
int str2[21][21];
int x,y,k;
const int dx[4]={1,-1,0,0};
const int dy[4]={0,0,1,-1};
bool dir(int p,int q)                         //判断是否在表格内。
{
    return p>=0&&q>=0&&p<x&&q<y;
}
void findpath(int p,int q)                    //寻找能通过的点。
{
    int nx,ny,i;
    str2[p][q]=1;                             //该位置更改为1;
    for (i=0;i<4;i++)                         //四次循环搜索点。
    {
        nx=p+dx[i];
        ny=q+dy[i];
        if (dir(nx,ny)&&str1[nx][ny]!='#'&&str2[nx][ny]!=1)  //如果在区域内且该点没有到达过且不为#  
        {
            findpath(nx,ny);                                  //继续搜索
            k++;                                             //能到达的点的数量加1
        }
    }

}
int main()
{
    while (cin>>y>>x)
    {
        int i,j,p,q;
        k=1;
        if (x==0||y==0)
            break;
        for (i=0; i<x; i++)
        {
            for (j=0; j<y; j++)
            {
                cin>>str1[i][j];
                if (str1[i][j]=='@')           //记录@的位置。
                {
                    p=i;
                    q=j;
                }
            }
        }
        for (i=0;i<x;i++)
            for (j=0;j<y;j++)                
            str2[i][j]=0;                     //str2来表示是否走过这个位置
        findpath(p,q);                        //从@的位置开始搜索
        cout<<k<<endl;                        //输出能到达的点的数量
    }
    return 0;
}


解题思路:

题目大意是由表格中@位置出发,向四周寻找能达到"."的数目(包括@本身);

这道题用的是递归的思想,从@位置出发,先通过函数findpath中的循环搜索能到达的“.”,如果某一方向第一次就能到达,就递归,以该店为起点再一次的搜索,直到没有能到达的’.'点后返回然后向其他方向搜索,同时统计数目。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值