hdu1029 Ignatius and the Princess IV——多数元素

41 篇文章 1 订阅

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 34766    Accepted Submission(s): 15165


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
  
  
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
  
  
3 5 1



题意:找出一组数中总个数超过50%的数

啊哈算法最后作者有提到这个问题 书中用了很多不同的算法将复杂度从n^2(普通排序)到nlogn(快排)到n+m(类似桶排序)到n(分治)

下面的算法用了一个特性:从序列中去除任意两个不相等的数不会改变要寻找的数 
因为本来这个数的个数就超过50% 其他数的个数的总和都没有超过它 所以去掉它和任意另外一个数肯定不会改变这个数的特性 就更不用说如果去掉的都不是这个数了

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <cmath>
#include <vector>
#define max_ 1000010
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
int n;
ll num[max_];
int main(int argc, char const *argv[])
{
	while(scanf("%d",&n)!=EOF)
	{
		int i;
		for(i=1;i<=n;i++)
			scanf("%lld",&num[i]);
		ll c;
		int cnt=0;
		i=1;
		while(i<=n)
		{
			c=num[i];
			cnt=1;
			while(i<=n&&cnt>0)
			{
				i++;
				if(c==num[i])
					cnt++;
				else
					cnt--;
			}
			if(i==n+1)
				printf("%lld\n",c );
			else
				i++;
		}
	}
	return 0;
}


  
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值