POJ - 3279 Fliptile —— 二维开关

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14217 Accepted: 5232

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题意:

给定n*m的矩阵,每次可以反转该点与其上下左右四个方向的点,问最少要操作几次能使其变成全0,输出要反转的中心点的位置

思路:

二维开关

注意到只要确定了第一行操作需要的地方,后面的行都可以由此推出来

暴力枚举第一行的操作,推出后面的操作并计算最后一行是否能满足

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <cmath>
#include <vector>
#define max_ 20
#define inf 0x3f3f3f3f
#define ll long long
#define les 1e-8
using namespace std;
int n,m;
int mp[max_][max_];
int num[max_][max_];
int out[max_][max_];
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int getsum(int x,int y)
{
	int sum=num[x][y];
	for(int k=0;k<4;k++)
	{
		int tx=x+dir[k][0];
		int ty=y+dir[k][1];
		sum+=num[tx][ty];
	}
	return sum;
}
int main(int argc, char const *argv[]) {
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			scanf("%d",&mp[i][j]);
		}
	}
	int ans=n*m+1;
	for(int i=0;i<(1<<m);i++)
	{
		memset(num,0,sizeof num);
		int sum=0,f=1;
		int tmp=i;
		for(int j=m;j>=1;j--)
		{
			if(tmp&1)
			{
				num[1][j]=1;
				sum++;
			}
			tmp=tmp>>1;
		}
		for(int i=1;i<n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				if((getsum(i,j)+mp[i][j])&1)
				{
					sum++;
					num[i+1][j]=1;
				}
			}
		}
		for(int i=1;i<=m;i++)
		{
			if((getsum(n,i)+mp[n][i])&1)
			{
				f=0;
				break;
			}
		}
		if(f&&sum<ans)
		{
			ans=sum;
			for(int i=1;i<=n;i++)
			{
				for(int j=1;j<=m;j++)
				{
					out[i][j]=num[i][j];
				}
			}
		}
	}
	if(ans==n*m+1)
	{
		printf("IMPOSSIBLE\n");
	}
	else
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				if(j!=1)
				printf(" " );
				printf("%d",out[i][j] );
			}
			printf("\n" );
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值