Prime Distance(大素数筛选)

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.

Your program is given 2 numbers: L and U (1≤L<U≤2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L≤C1<C2≤U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L≤D1<D2≤U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.
  

解析:题意是给两个数,找出这两个数中所有的素数并把相邻的两个素数之差最小的两个数,和最大的两个相邻素数。

开始用暴力,直接超时。后来看了一下网上的代码

#include <stdio.h>  
  
__int64 l,u;  
int prime[47000];  
int prime1[1000100];  
int is[47000],is1[1000100];  
int cou=0,cou1;  
int min,max;  
int a,b;  
  
void getPrime()  
{  
    for(int i=2;i<46400;i++) is[i]=1;  
    for(int i=2;i<46400;i++)  
        {  
            if(is[i])  prime[cou++]=i;  
            for(int j=0;j<cou&&i*prime[j]<46400;j++)  
            {  
                is[i*prime[j]]=0;  
                if(i%prime[j]==0)  break;  
            }  
       }  
}  
  
void solve(__int64 l,__int64 u)  
{  
    __int64 p,s;  
    if(u<46400)  
    {  
      for(int i=l;i<=u;i++)  
       if(is[i])  
       prime1[cou1++]=i-l;  
    }  
    else  
    {  
      for(int i=0;i<=u-l;i++)   is1[i]=1;  
      for(int i=0;i<cou&&prime[i]*prime[i]<=u;i++)  
         {  
             s=l/prime[i];  
             if(s*prime[i]<l)  s++;  
             if(s<=1) s++;  
             for(__int64 j=s;j*prime[i]<=u;j++)  
              {  
                //   printf("%I64d\n",j*prime[i]);  
                  p=(int)j*prime[i]-l;  
                  is1[p]=0;  
              }  
         }  
      for(int i=0;i<=u-l;i++)  
       if(is1[i])  
       prime1[cou1++]=i;  
    }  
}  
int main()  
{   
    getPrime();  
    while(scanf("%lld %lld",&l,&u)!=EOF)  
    {  
       cou1=0;  
       solve(l,u);  
       min=2147483647;  
       max=-1;  
       if(cou1<2)  
       {  
           printf("There are no adjacent primes.\n");  
           continue;  
       }  
       for(int i=0;i<cou1-1;i++)  
       {  
           if(prime1[i+1]-prime1[i]<min)  
           {  
               min=prime1[i+1]-prime1[i];  
               a=i;  
           }  
           if(prime1[i+1]-prime1[i]>max)  
           {  
               max=prime1[i+1]-prime1[i];  
               b=i;  
           }  
       }  
       printf("%I64d,%I64d are closest, %I64d,%I64d are most distant.\n",prime1[a]+l,prime1[a+1]+l,prime1[b]+l,prime1[b+1]+l);  
    }  
}  




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值